firefox - *** loading the extensions datasource

Sean McNeil sean at
Fri Jun 18 09:33:20 PDT 2004

On Fri, 2004-06-18 at 09:21, Joe Marcus Clarke wrote:
> On Fri, 2004-06-18 at 03:59, Sean McNeil wrote:
> > OK,
> > 
> > So I have firefox working as root and it doesn't print anything when I
> > run it.
> > 
> > As my regular user, it print the
> > 
> > *** loading the extensions datasource
> > 
> > and then core dumps.  I think I have some old cruft somewhere, but I
> > can't find it.  I deleted everything in /usr/X11R6/lib/browser_plugins
> > and I tried it from a new account that didn't have any gnome usage
> > before I tried to run firefox.  I get the same thing: message then core
> > dump.
> > 
> > Where could these extensions be and how can I purge them.  Also, why
> > would root not try to load them?
> The extensions are kept in the main Firefox directory.  Try removing
> /usr/X11R6/lib/firefox/lib/firefox-0.9/chrome/chrome.rdf and
> /usr/X11R6/lib/firefox/lib/firefox-0.9/extensions, then run it as root,
> then try running it as a normal user again.
> Joe

OK, that did it somehow.

rm -rf /usr/X11R6/lib/firefox/lib/firefox-0.9/chrome/chrome.rdf
(how to run 3 times before it worked again. 1st it core dumped, 2nd it

then as normal user, I had to tell it to import instead of ignore old
settings. then it core dumped again in a different place saying I didn't
have access to some files.  Finally, it works.

This has been a very interesting issue.

More information about the freebsd-gnome mailing list