gDesklets FreeBSD Python problem

Sander Smid s.smid at
Sun Jun 13 18:02:23 GMT 2004


First of all, thank you for the work you've done (and still do) to maintain this port. 
The reason I mail you is not only to thank you but I do have a problem with this port.

I installed gdesklets from the port collection on my FreeBSD 5.2.1 notebook. So far without any problems.
When I try to start gdesklets I get python errors and I have no clue how to solve them.
I run FreeBSD 5.2.1, XFree86, XFCE. I already updated my whole system buit that didn't work.. I also tried to install the gdesklets-callender port and let that one install gdesklets but that didn't work either.

This what I get:
root at laptop [/usr/ports/deskutils/gdesklets] >gdesklets
Traceback (most recent call last):
  File "/usr/X11R6/bin/gdesklets", line 10, in ?
    from main import init
  File "/usr/X11R6/share/gnome/gdesklets/main/", line 37, in ?
    from utils.i18n import Translator
  File "/usr/X11R6/share/gnome/gdesklets/utils/", line 1, in ?
    from FileWatcher import FileWatcher
  File "/usr/X11R6/share/gnome/gdesklets/utils/", line 3, in ?
    import gtk
  File "/usr/local/lib/python2.3/site-packages/gtk-2.0/gtk/", line 43, in ?
    from _gtk import *
ImportError: /usr/local/lib/python2.3/site-packages/gtk-2.0/gtk/ Undefined symbol "PyUnicodeUCS2_FromUnicode"

Do you have any idea what's causing this problem?

I'm not a member of this mailinglist so please reply to s.smid (@dddd) chello (d.tttt) nl

Thanks in advantage,

More information about the freebsd-gnome mailing list