gnome2-power-tools failure

J. W. Ballantine jwb at
Wed Jun 9 16:02:09 GMT 2004


Tried to install gnome2-power-tools after CTM'ing to the current
level this morning and it failed with:

===>   gnome2-power-tools-2.6.1 depends on file: /usr/X11R6/lib/epiphany/extens
ions/ - not found
===>    Verifying reinstall for /usr/X11R6/lib/epiphany/extensions/libgesturese in /usr/ports/www/epiphany-extensions

 By default epiphany-extensions builds with www/mozilla support, but you can
 change this by defining WITH_MOZILLA to one of the following values:


Epiphany-extensions also supports the following tunable option(s):
        WITH_OPENSP=yes         Enable support for OpenSP SGML validation

===>  Vulnerability check disabled
===>  Extracting for epiphany-extensions-0.8.2
>> Checksum OK for gnome2/epiphany-extensions-0.8.2.tar.bz2.
===>  Patching for epiphany-extensions-0.8.2
===>  Applying FreeBSD patches for epiphany-extensions-0.8.2
===>   epiphany-extensions-0.8.2 depends on executable: epiphany - found
===>   epiphany-extensions-0.8.2 depends on file: /usr/X11R6/lib/mozilla/compon
ents/ - found
===>   epiphany-extensions-0.8.2 depends on executable: gmake - found
===>   epiphany-extensions-0.8.2 depends on file: /usr/local/bin/libtool13 - 
===>   epiphany-extensions-0.8.2 depends on shared library: X11.6 - found
===>  Configuring for epiphany-extensions-0.8.2
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel

(REMOVED rest of configure and good c++/c lines)

rm -f .libs/sgml-validator.lo
cc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../extensions/error-viewer/mozilla 
-I../../extensions/error-viewer/opensp -I../../extensions
/error-viewer -I../../include -DORBIT2=1 -D_THREAD_SAFE 
-I/usr/local/include/libxml2 -I/usr/local/include -I/usr/local/include/atk-1
.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include 
-I/usr/local/include/bonobo-activation-2.0 -I/usr/local/include/o
rbit-2.0 -I/usr/local/include/libart-2.0 -I/usr/local/include/libbonobo-2.0 
-I/usr/X11R6/include/libglade-2.0 -I/usr/X11R6/include/g
tk-2.0 -I/usr/X11R6/lib/gtk-2.0/include -I/usr/X11R6/include 
-I/usr/X11R6/include/pango-1.0 -I/usr/local/include/freetype2 -I/usr/X1
1R6/include/epiphany-1.2 -I/usr/X11R6/include/libgnomeui-2.0 
-I/usr/X11R6/include/libbonoboui-2.0 -I/usr/X11R6/include/gnome-vfs-2.0
 -I/usr/X11R6/lib/gnome-vfs-2.0/include -I/usr/X11R6/include/gnome-vfs-module-2
.0 -I/usr/X11R6/include/gconf/2 -I/usr/X11R6/include/
libgnome-2.0 -I/usr/X11R6/include/libgnomecanvas-2.0 
-DSHARE_DIR=\"/usr/X11R6/share/gnome/epiphany-extensions\" -DEPHY_EXTENSIONS_LO
CALEDIR=\"/usr/X11R6/share/locale\" -DG_DISABLE_DEPRECATED 
-I/usr/X11R6/include -D_THREAD_SAFE -O -pipe -c sgml-validato
r.c -Wp,-MD,.deps/sgml-validator.TPlo  -fPIC -DPIC -o .libs/sgml-validator.lo
sgml-validator.c: In function `sgml_validator_append_internal':
sgml-validator.c:441: syntax error before `*'
sgml-validator.c:444: `append_data' undeclared (first use in this function)
sgml-validator.c:444: (Each undeclared identifier is reported only once
sgml-validator.c:444: for each function it appears in.)
gmake[4]: *** [sgml-validator.lo] Error 1
gmake[4]: Leaving directory `/usr/ports/www/epiphany-extensions/work/epiphany-e
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/www/epiphany-extensions/work/epiphany-e
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/www/epiphany-extensions/work/epiphany-e
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/www/epiphany-extensions/work/epiphany-e
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/www/epiphany-extensions.
*** Error code 1

Stop in /usr/ports/www/epiphany-extensions.
*** Error code 1

Stop in /usr/ports/x11/gnome2-power-tools.
*** Error code 1

Stop in /usr/ports/x11/gnome2-power-tools.

This is on a 4.10-stable system with gnome-2.6 installed and 
epiphany-extensions is the first program gnome2-power-tools tries to build.  
The  says the
build failure is unknown to it.

Jim Ballantine

----------  In Response to your message -------------

>  Date:  Fri, 04 Jun 2004 17:22:54 -0400
>  To:  "J. W. Ballantine" <jwb at>
>  From:  Joe Marcus Clarke <marcus at>
>  Subject:  Re: gnome2-power-tools failure and others
>  --=-P3f8H7H4jxAkLtRtruCh
>  Content-Type: text/plain
>  Content-Transfer-Encoding: quoted-printable
>  On Thu, 2004-06-03 at 13:35, J. W. Ballantine wrote:
>  > I tried to install gnome2-power-tools via portupgrade -n gnome2-power-too=
>  ls,
>  > and it failed with (tail of log) :
>  Fixed, thanks for reporting.
>  Joe
>  --=20
>  PGP Key :
>  --=-P3f8H7H4jxAkLtRtruCh
>  Content-Type: application/pgp-signature; name=signature.asc
>  Content-Description: This is a digitally signed message part
>  Version: GnuPG v1.2.4 (FreeBSD)
>  iD8DBQBAwOgtb2iPiv4Uz4cRAioUAKCwgOpkYGQK7csqf+W6NrtZGuh8RwCgqg1+
>  0Ex3mCW+unXdidXebUXK6D4=
>  =l+8V
>  -----END PGP SIGNATURE-----
>  --=-P3f8H7H4jxAkLtRtruCh--

More information about the freebsd-gnome mailing list