8.0-RELEASE / gpart / GPT / marking a partition as "active"

Robert Noland rnoland at FreeBSD.org
Wed Jan 20 12:21:52 UTC 2010

On Tue, 2010-01-19 at 19:11 +0200, Dan Naumov wrote:
> It seems that quite a few BIOSes have serious issues booting off disks
> using GPT partitioning when no partition present is marked as
> "active". See http://www.freebsd.org/cgi/query-pr.cgi?pr=115406&cat=bin
> for a prime example.
> In 8.0-RELEASE, using gpart, setting a slice as "active" in MBR
> partitioning mode is trivial, ie:
> gpart set -a active -i 1 DISKNAME
> However, trying to do the same thing with GPT partitioning yields no results:
> gpart set -a active -i 1 DISKNAME
> gpart: attrib 'active': Device not configured
> As a result of this issue, I can configure and make a succesfull
> install using GPT in 8.0, but I cannot boot off it using my Intel
> D945GCLF2 board.

I have the same board... 

> I have found this discussion from about a month ago:
> http://www.mail-archive.com/freebsd-stable@freebsd.org/msg106918.html
> where Robert mentions that "gpart set -a active -i 1" is no longer
> needed in 8-STABLE, because the pmbr will be marked as active during
> the installation of the bootcode. Is there anything I can do to
> archieve the same result in 8.0-RELEASE or is installing from a
> snapshop of 8-STABLE my only option?

Prior to fixing gpart to take care of this, I used fdisk to set the
active partition.  gpart knows the disk is GPT and GPT doesn't have an
"active" parameter, so the above command doesn't (perhaps never) worked.

Basically, an "fdisk -a /dev/devX" is what you want...


> Thanks.
> - Sincerely,
> Dan Naumov
Robert Noland <rnoland at FreeBSD.org>

More information about the freebsd-geom mailing list