zfs mount prior to rc.conf evaluations

Sean Bruno sean_bruno at yahoo.com
Mon Aug 19 22:57:17 UTC 2013

We have a few slightly goofy rc.conf variables that require /usr/bin/ to
be mounted before rc.conf is evaluated, e.g:

netwait_ip="$(grep default /etc/start_if.* | awk '{print $4}')"

This worked in our UFS world, but in ZFS land with zroot/usr/bin being a
seperate mountpoint, its not mounted at the point that rc.conf is
evaluated causing a few things to fail.

This appears to be solved by applying

But, is there a better way to do this?  I *could* make zroot/usr and
zroot/usr/bin just be part of zroot and not seperate mountpoints to
solve the issue as well.

Thoughts or alternative solutions?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: This is a digitally signed message part
URL: <http://lists.freebsd.org/pipermail/freebsd-fs/attachments/20130819/2bfee06a/attachment.sig>

More information about the freebsd-fs mailing list