zpool raidz2 missing space?

Edho P Arief edho at myconan.net
Wed Jun 29 08:44:41 UTC 2011

On Wed, Jun 29, 2011 at 2:10 PM, Edho P Arief <edho at myconan.net> wrote:
> My zpool seems to be missing ~500G of space. One of the disk
> originally sized at around 1.65T which probably caused it but I've
> replaced the partition and it should show full 4*1.8T (~7.2T) but it
> still shows old capacity (4*1.65T ~ 6.6T).
> What should be done? I've tried export/import cycle but the result is same.

sorry, seems like reboot cycle solved it.

[root at einhart ~]# zpool status
  pool: dpool
 state: ONLINE
 scan: scrub in progress since Wed Jun 29 15:35:22 2011
    24.4G scanned out of 4.61T at 55.4M/s, 24h6m to go
    0 repaired, 0.52% done

        NAME                                            STATE     READ
        dpool                                           ONLINE       0
    0     0
          raidz2-0                                      ONLINE       0
    0     0
            gptid/fe13fc94-9bfe-11e0-bd6e-0030678cf5c1  ONLINE       0
    0     0
            gptid/0dc1601d-9f95-11e0-9a98-0030678cf5c1  ONLINE       0
    0     0
            gptid/1e76f2ad-9d5d-11e0-997b-0030678cf5c1  ONLINE       0
    0     0
            gptid/8d23200a-9d5c-11e0-997b-0030678cf5c1  ONLINE       0
    0     0

errors: No known data errors
[root at einhart ~]# zpool list
dpool  7.06T  4.61T  2.45T    65%  1.00x  ONLINE  -
[root at einhart ~]# glabel status
                                      Name  Status  Components
gptid/94d650c8-a05d-11e0-b636-0030678cf5c1     N/A  ad4p1
gptid/0dc1601d-9f95-11e0-9a98-0030678cf5c1     N/A  ad4p5
gptid/1b214d9b-9f95-11e0-9a98-0030678cf5c1     N/A  ad4p9
gptid/025527eb-9d5d-11e0-997b-0030678cf5c1     N/A  ad6p1
gptid/1e76f2ad-9d5d-11e0-997b-0030678cf5c1     N/A  ad6p5
gptid/2570c3bb-9d5d-11e0-997b-0030678cf5c1     N/A  ad6p9
gptid/6b426779-9d5c-11e0-997b-0030678cf5c1     N/A  ad8p1
gptid/8d23200a-9d5c-11e0-997b-0030678cf5c1     N/A  ad8p5
gptid/99ee1556-9d5c-11e0-997b-0030678cf5c1     N/A  ad8p9
gptid/31d15ce9-9bfe-11e0-bd6e-0030678cf5c1     N/A  ad10p1
gptid/fe13fc94-9bfe-11e0-bd6e-0030678cf5c1     N/A  ad10p5
gptid/128af023-9bff-11e0-bd6e-0030678cf5c1     N/A  ad10p9
                                 ufs/root0     N/A  mirror/gm0a
                               label/swap0     N/A  stripe/gs0b
                                 ufs/home0     N/A  stripe/gs0d
[root at einhart ~]# zfs list
dpool                  2.23T  1.14T   174K  legacy
dpool/data             2.23T  1.14T  2.23T  legacy
dpool/data/documents    888M  1.14T   888M  legacy
dpool/jails             267M  1.14T   186K  legacy
dpool/jails/debian      267M  1.14T   267M  legacy
dpool/ports-distfiles  2.61G  1.14T  2.61G  /usr/ports/distfiles
dpool/ports-tmp        90.6M  1.14T  90.6M  /.ports-tmp
dpool/src.cvs           562M  1.14T   562M  /usr/src.cvs
dpool/srv              31.0M  1.14T  31.0M  legacy
dpool/usr.obj           221K  1.14T   209K  /usr/obj
dpool/usr.src          2.22G  1.14T  2.22G  /usr/src
[root at einhart ~]# df -h
Filesystem               Size    Used   Avail Capacity  Mounted on
/dev/ufs/root0           9.7G    6.5G    2.5G    72%    /
devfs                    1.0k    1.0k      0B   100%    /dev
/dev/ufs/home0            46G    755M     42G     2%    /usr/home
procfs                   4.0k    4.0k      0B   100%    /proc
linprocfs                4.0k    4.0k      0B   100%    /compat/linux/proc
dpool/data               3.4T    2.2T    1.1T    66%    /data
dpool/srv                1.1T     31M    1.1T     0%    /srv
dpool/data/documents     1.1T    888M    1.1T     0%    /data/documents
dpool/jails              1.1T    186k    1.1T     0%    /jails
dpool/jails/debian       1.1T    266M    1.1T     0%    /jails/debian
dpool/ports-tmp          1.1T     90M    1.1T     0%    /.ports-tmp
dpool/usr.obj            1.1T    209k    1.1T     0%    /usr/obj
dpool/ports-distfiles    1.1T    2.6G    1.1T     0%    /usr/ports/distfiles
dpool/usr.src            1.1T    2.2G    1.1T     0%    /usr/src
dpool/src.cvs            1.1T    562M    1.1T     0%    /usr/src.cvs
/data/documents          1.1T    888M    1.1T     0%    /usr/home/edho/Documents
/data/downloads          3.4T    2.2T    1.1T    66%    /usr/home/edho/Downloads
[root at einhart ~]# zdb
    version: 28
    name: 'dpool'
    state: 0
    txg: 407886
    pool_guid: 5265065684459342039
    hostid: 4266313884
    hostname: 'einhart'
    vdev_children: 1
        type: 'root'
        id: 0
        guid: 5265065684459342039
            type: 'raidz'
            id: 0
            guid: 10113259324866791715
            nparity: 2
            metaslab_array: 23
            metaslab_shift: 36
            ashift: 12
            asize: 7314369150976
            is_log: 0
                type: 'disk'
                id: 0
                guid: 850395506991012944
                path: '/dev/gptid/fe13fc94-9bfe-11e0-bd6e-0030678cf5c1'
                phys_path: '/dev/gptid/fe13fc94-9bfe-11e0-bd6e-0030678cf5c1'
                whole_disk: 0
                DTL: 164
                type: 'disk'
                id: 1
                guid: 11140108939464482570
                path: '/dev/gptid/0dc1601d-9f95-11e0-9a98-0030678cf5c1'
                phys_path: '/dev/gptid/0dc1601d-9f95-11e0-9a98-0030678cf5c1'
                whole_disk: 1
                DTL: 173
                type: 'disk'
                id: 2
                guid: 2470764073478818097
                path: '/dev/gptid/1e76f2ad-9d5d-11e0-997b-0030678cf5c1'
                phys_path: '/dev/gptid/1e76f2ad-9d5d-11e0-997b-0030678cf5c1'
                whole_disk: 0
                DTL: 168
                type: 'disk'
                id: 3
                guid: 3492436401681256292
                path: '/dev/gptid/8d23200a-9d5c-11e0-997b-0030678cf5c1'
                phys_path: '/dev/gptid/8d23200a-9d5c-11e0-997b-0030678cf5c1'
                whole_disk: 0
                DTL: 165

O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

More information about the freebsd-fs mailing list