[ZFSv28] Loader hangs, import failes, zfs filesystem unavailable.

Bartosz Stec bartosz.stec at it4pro.pl
Sat Jun 4 16:56:07 UTC 2011

W dniu 2011-06-04 14:21, Bartosz Stec pisze:
> W dniu 2011-06-03 14:16, Pawel Jakub Dawidek pisze:
>> On Thu, Jun 02, 2011 at 06:58:10PM +0200, Bartosz Stec wrote:
>>> Hi list,
>>> Today I needed to shut down my home server (FreeSBD9-CURRENT, 3 x
>>> 40GB ATA HDD in RADZ1, ZFS only, GPT, i386) for a moment. After
>>> power up, loader started to spin cursor indifinitely, and didn't
>>> load the kernel. No error messages, no hints, just spinning cursor.
>>> I tried booting from other HDDs in case that bootstrap area errors
>>> on single hdd but no luck.
>>> I wanted to play with latest current LiveFS snapshot (with ZFSv28
>>> support), but apparently latest one is from february??
>>> Finally I ended with mfsBSD from http://mfsbsd.vx.sk/
>>> I've downloaded "8.2-RELEASE-i386 with ZFSv28 special edition
>>> <http://mfsbsd.vx.sk/iso/mfsbsd-se-8.2-zfsv28-i386.iso>" iso, burned
>>> it and booted machine. Here's what happened when i was trying to
>>> import zpool:
>>>     mfsbsd# zpool status
>>>     no pools available
>>>     mfsbsd# zpool import
>>>        pool: zroot
>>>          id: 16074929158756467860
>>>       state: ONLINE
>>>     status: The pool was last accessed by another system.
>>>     action: The pool can be imported using its name or numeric
>>>     identifier and
>>>              the '-f' flag.
>>>         see: http://www.sun.com/msg/ZFS-8000-EY
>>>     config:
>>>              zroot                                           ONLINE
>>>                raidz1-0                                      ONLINE
>>>                  gptid/2ea57c66-bc69-11df-8955-0050dad823cd  ONLINE
>>>                  gptid/5bc92016-6852-11df-a16c-0050dad823cd  ONLINE
>>>                  gptid/87d467cc-bc3b-11df-8066-0050dad823cd  ONLINE
>>>     mfsbsd# zpool import -f zroot
>>>     cannot import 'zroot': one or more devices is currently unavailable
>> Is there anything that may keep any of those vdevs open?
>> Try setting vfs.zfs.debug to 1 before import.
It seems that LiveFS is now included in bootonly ISO, so I made another 
attempt using FreeBSD-9.0-CURRENT-201105-i386-bootonly.iso image. I 
tried importing with debugging enabled, but dmesg output was the same as 
in my previous message.

I had so much faith in raidz + snapshots, that I have absolutely no 
backups of this system :( I don't care about time which is needed to 
find a problem and possible fix, but I am really worried about my data 
now. What else could I do?
And yes, I know that I shouldn't treat CURRENT as a stable and reliable 
system, and you never have too much backups. I just didn't realized how 
important data on this machine is until I realized that maybe I just 
lost it... Crap.

Bartosz Stec

More information about the freebsd-fs mailing list