NanoBSD with ZFS

oschonef at oschonef at
Fri Apr 27 18:27:19 UTC 2007

Hello Pawel,

Eines schoenen Tages schrieb Pawel Jakub Dawidek:
> > Unfortunatly not! "zpool create" tries to write to /boot/zfs/.zpool.cache
> > (possibly a temporary) which cannot be written. If I symlink
> > /boot/zfs/.zpool.cache -> /etc/zfs/.zpool.cache, I end up with the
> > cache being written to /etc/zfs/.zpool.cache. This file however is then not
> > copied or moved to /etc/zfs/zpool.cache, but of the symlinks.
> > If I link /boot/zfs/.zpool.cache to /etc/zfs/zpool.cache, the file is
> > populated.
> > After a reboot however the file, which was copied there by the rc.initdiskless,
> > seems not to containt, what zfs expects, since the filesystems are not
> > mounted and I need to import the pool by hand.
> And /boot/zfs -> /etc/zfs symlink?

Ok, this solved the problem with the temporary file. I should have tried
that by myself. ;)
The filesystems are still not mounted after reboot. This is, because I
preloaded the zfs.ko module. ZFS seems to try to load the cache, but
rc.initdiskless has not been run and therefore there is no zpool.cache file.
If I load the the module from a rc.d script, which needs to be run before
rc.d/zfs, it works as expected.
If the loader could preload files from a different partition
(ffs, w/o bsdlabel), it would be possibe to preload the module. My first
experiments however failed. But since it works the way I described above
this feature would be nice to have, but is not mandatory ;)

And remember: "To Infinity And Far Beyond ... Somehow?!"

Hi! I'm a .signature virus! Copy me in your ~/.signature
to help me spread!             <- Save this lifeform ;-)

More information about the freebsd-fs mailing list