E on FreeBSD: [linimon at FreeBSD.org: svn commit: r491080 - in head: devel/efl devel/google-perftools graphics/blender lang/ponyc net-p2p/monero-cli net/tigervnc science/rubygem-ruby-dcl www/rubygem-passenger x11-toolkits/rubygem-tk]

Mark Linimon linimon at lonesome.com
Thu Jan 24 05:13:37 UTC 2019


FYI.

mcl

devel/efl                       enlightenment at FreeBSD.org
devel/google-perftools          yuri at FreeBSD.org
graphics/blender                FreeBSD at Shaneware.biz
lang/ponyc                      greg at unrelenting.technology
net-p2p/monero-cli              vd at FreeBSD.org
net/tigervnc                    meta at FreeBSD.org
science/rubygem-ruby-dcl        murashin at gfd-dennou.org
www/rubygem-passenger           osa at FreeBSD.org
x11-toolkits/rubygem-tk         nmingotti at gmail.com

----- Forwarded message from Mark Linimon <linimon at FreeBSD.org> -----

Date: Thu, 24 Jan 2019 05:09:48 +0000 (UTC)
From: Mark Linimon <linimon at FreeBSD.org>
To: ports-committers at freebsd.org, svn-ports-all at freebsd.org, svn-ports-head at freebsd.org
Subject: svn commit: r491080 - in head: devel/efl devel/google-perftools graphics/blender lang/ponyc net-p2p/monero-cli net/tigervnc science/rubygem-ruby-dcl www/rubygem-passenger x11-toolkits/rubygem-tk

Author: linimon
Date: Thu Jan 24 05:09:48 2019
New Revision: 491080
URL: https://svnweb.freebsd.org/changeset/ports/491080

Log:
  Conditionalize the dependence of libunwind to x86-only to allow building
  these ports on !x86.
  
  libunwind is only available for x86; lang/ruby* already expresses this
  correctly.  Some of the rubygems did not: for the ones that already had
  USE_RUBY, the dependency was overspecified in the first place.
  
  Tested for no-harm on amd64.
  
  While here, pet portlint where appropriate.
  
  Approved by:	portmgr (tier-2 blanket)

Modified:
  head/devel/efl/Makefile
  head/devel/google-perftools/Makefile
  head/graphics/blender/Makefile
  head/lang/ponyc/Makefile
  head/net-p2p/monero-cli/Makefile
  head/net/tigervnc/Makefile
  head/science/rubygem-ruby-dcl/Makefile
  head/www/rubygem-passenger/Makefile
  head/x11-toolkits/rubygem-tk/Makefile

Modified: head/devel/efl/Makefile
==============================================================================
--- head/devel/efl/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/devel/efl/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -20,8 +20,7 @@ LIB_DEPENDS=	libgif.so:graphics/giflib \
 		libfreetype.so:print/freetype2 \
 		libfontconfig.so:x11-fonts/fontconfig \
 		libdbus-1.so:devel/dbus \
-		libsndfile.so:audio/libsndfile \
-		libunwind.so:devel/libunwind
+		libsndfile.so:audio/libsndfile
 
 # lib/libeio.so.1
 CONFLICTS_INSTALL=	libeio
@@ -168,6 +167,11 @@ CONFIGURE_ARGS+=		--disable-ibus --with-glib=no
 
 .if empty(PORT_OPTIONS:MOPENGL) && empty(PORT_OPTIONS:MOPENGLES)
 CONFIGURE_ARGS+=		--with-opengl=none
+.endif
+
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+=	libunwind.so:devel/libunwind
 .endif
 
 .if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"

Modified: head/devel/google-perftools/Makefile
==============================================================================
--- head/devel/google-perftools/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/devel/google-perftools/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -18,8 +18,6 @@ BROKEN_powerpc=		fails to build: assembly not supporte
 BROKEN_powerpc64=	fails to build: assembly not supported, see PR\#94: http://code.google.com/p/google-perftools/issues/detail?id=94&can=1
 BROKEN_sparc64=		fails to build: assembly not supported, see PR\#94: http://code.google.com/p/google-perftools/issues/detail?id=94&can=1
 
-LIB_DEPENDS=	libunwind.so:devel/libunwind
-
 DOCSDIR=	${PREFIX}/share/doc/gperftools
 
 USES=		compiler gmake libtool
@@ -62,6 +60,11 @@ CXXFLAGS+=	-fno-builtin
 
 .if ${ARCH} == "amd64"
 CONFIGURE_ARGS+=--enable-frame-pointers
+.endif
+
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+=	libunwind.so:devel/libunwind
 .endif
 
 post-build:

Modified: head/graphics/blender/Makefile
==============================================================================
--- head/graphics/blender/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/graphics/blender/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -47,6 +47,14 @@ OPTIONS_SUB=	yes
 
 .include "${.CURDIR}/Makefile.options"
 
+# libunwind is specific to amd64/i386
+OPTIONS_EXCLUDE_aarch64=	CAMERATRACK
+OPTIONS_EXCLUDE_armv6=		CAMERATRACK
+OPTIONS_EXCLUDE_armv7=		CAMERATRACK
+OPTIONS_EXCLUDE_powerpc=	CAMERATRACK
+OPTIONS_EXCLUDE_powerpc64=	CAMERATRACK
+OPTIONS_EXCLUDE_powerpcspe=	CAMERATRACK
+
 ALEMBIC_CMAKE_BOOL=		WITH_ALEMBIC
 ALEMBIC_LIB_DEPENDS=		libAlembic.so:graphics/alembic
 # note that this needs to be set to match alembics hdf5 option

Modified: head/lang/ponyc/Makefile
==============================================================================
--- head/lang/ponyc/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/lang/ponyc/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -14,7 +14,6 @@ LICENSE_FILE=	${WRKSRC}/LICENSE
 ONLY_FOR_ARCHS=		aarch64 amd64
 ONLY_FOR_ARCHS_REASON=	Undefined reference to __atomic_compare_exchange_8
 
-LIB_DEPENDS=	libunwind.so:devel/libunwind
 BUILD_DEPENDS=	llvm-link${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
 RUN_DEPENDS=	llvm-link${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
 
@@ -52,6 +51,11 @@ PONYARCH?=	armv8-a
 .elif "${ARCH}" == amd64
 # Can't use 'x86-64' because atomics are required
 PONYARCH?=	core2
+.endif
+
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+=	libunwind.so:devel/libunwind
 .endif
 
 .if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085

Modified: head/net-p2p/monero-cli/Makefile
==============================================================================
--- head/net-p2p/monero-cli/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/net-p2p/monero-cli/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -35,7 +35,6 @@ LIB_DEPENDS=	\
 		libpgm.so:net/openpgm \
 		libsodium.so:security/libsodium \
 		libunbound.so:dns/unbound \
-		libunwind.so:devel/libunwind \
 		libzmq.so:net/libzmq4
 BUILD_DEPENDS=	${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson \
 		${LOCALBASE}/include/zmq.hpp:net/cppzmq
@@ -78,6 +77,11 @@ LD_EMULATION=	elf64ppc
 
 CMAKE_ARGS+=	-DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
 
+.endif
+
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+=	libunwind.so:devel/libunwind
 .endif
 
 CMAKE_ARGS+=	-DMANUAL_SUBMODULES:BOOL=ON

Modified: head/net/tigervnc/Makefile
==============================================================================
--- head/net/tigervnc/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/net/tigervnc/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -17,8 +17,7 @@ BUILD_DEPENDS=	${LOCALBASE}/include/GL/internal/dri_in
 		${LOCALBASE}/libdata/pkgconfig/fontutil.pc:x11-fonts/font-util \
 		${LOCALBASE}/include/FL/Fl.H:x11-toolkits/fltk \
 		bash:shells/bash
-LIB_DEPENDS=	libunwind.so:devel/libunwind \
-		libxshmfence.so:x11/libxshmfence \
+LIB_DEPENDS=	libxshmfence.so:x11/libxshmfence \
 		libfontconfig.so:x11-fonts/fontconfig
 # almost equivalent to x11-servers/xorg-server's
 RUN_DEPENDS=	${LOCALBASE}/share/X11/xkb/rules/base:x11/xkeyboard-config \
@@ -107,6 +106,11 @@ CONFIGURE_ARGS+=	\
 		--with-fontrootdir=${LOCALBASE}/share/fonts
 
 .include <bsd.port.pre.mk>
+
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+=	libunwind.so:devel/libunwind
+.endif
 
 TIGERVNC_XORG_PATCH_VER=	${MAKE} -C "${PORTSDIR}/x11-servers/xorg-server" -V PORTVERSION:R:S,\.,,g
 

Modified: head/science/rubygem-ruby-dcl/Makefile
==============================================================================
--- head/science/rubygem-ruby-dcl/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/science/rubygem-ruby-dcl/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -15,15 +15,13 @@ LICENSE_FILE=	${WRKSRC}/LICENSE.txt
 BUILD_DEPENDS=	rubygem-narray>=0.5.5:math/rubygem-narray
 LIB_DEPENDS=	libcdcl.so:science/cdcl \
 		libfontconfig.so:x11-fonts/fontconfig \
-		libfreetype.so:print/freetype2 \
-		libunwind.so:devel/libunwind
+		libfreetype.so:print/freetype2
 RUN_DEPENDS=	rubygem-narray>=0.5.5:math/rubygem-narray \
 		rubygem-narray_miss>0:math/rubygem-narray_miss
 
+USES=		gem gettext-runtime
 USE_GNOME=	atk cairo gdkpixbuf2 glib20 gtk20 pango
 USE_XORG=	ice sm x11
-
 USE_RUBY=	yes
-USES=		gem gettext-runtime
 
 .include <bsd.port.mk>

Modified: head/www/rubygem-passenger/Makefile
==============================================================================
--- head/www/rubygem-passenger/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/www/rubygem-passenger/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -42,7 +42,6 @@ SHEBANG_FILES=	src/cxx_supportlib/vendor-copy/libuv/gy
 
 LIB_DEPENDS+=	libuv.so:devel/libuv \
 		libcurl.so:ftp/curl \
-		libunwind.so:devel/libunwind \
 		libapr-1.so:devel/apr1
 
 BUILD_DEPENDS+=	rubygem-rack>=0:www/rubygem-rack

Modified: head/x11-toolkits/rubygem-tk/Makefile
==============================================================================
--- head/x11-toolkits/rubygem-tk/Makefile	Thu Jan 24 00:56:19 2019	(r491079)
+++ head/x11-toolkits/rubygem-tk/Makefile	Thu Jan 24 05:09:48 2019	(r491080)
@@ -10,8 +10,6 @@ COMMENT=	Ruby interface to TclTk-8.6
 
 LICENSE=	BSD2CLAUSE
 
-LIB_DEPENDS=	libunwind.so:devel/libunwind
-
 CONFIGURE_ARGS=--with-tcltkversion=8.6,8.6 \
 		--with-tk-include=${LOCALBASE}/include/tk8.6 \
 		--with-tcl-include=${LOCALBASE}/include/tcl8.6


----- End forwarded message -----


More information about the freebsd-enlightenment mailing list