confused about VMware on FreeBSD...

William Bulley web at
Wed Oct 25 10:23:01 PDT 2006

I have tried to research this issue on most of 2006's
worth of freebsd-emulation at, on Wikipedia,
using Google, on and by installing the
emulators/vmware3 port on FreeBSD 6.2-PRERELEASE.

I find that I am confused and unable to get to first
base with vmware.  I think I want the "free" VMware
Server application to be hosted on FreeBSD 6.2-PRERELEASE
which will then allow me to try "guest" operating systems
such as Windows XP and Linux on top of the VMware Server.

The documentation that comes with the emulators/vmware3
port (in file:///usr/X11R6/lib/vmware/help/index.htm and
in /usr/X11R6/share/doc/vmware3/*) doesn't seem to help.

I have run "vmware-wizard" to set up a virtual disk and
that seems to have worked.  When I run vmware (as normal
user, not root), I am asked for a license key or serial
number.  When I went to (to register and
obtain a free serial number), the serial number given me
does not work when entered into the GUI window asking
for a valid serial number before letting me "in".

My confusion is complicated by such terms as:

  VMware Workstation
  VMware Server
  emulators/vmware2 (marked as deprecated and broken)
  emulators/vmware3 (vmware3-,1)

and the fact that the "free" VMware Server download at:

is labled as:

  VMware Server (for Windows and Linux systems)
  Latest Version: 1.0.1 | 8/14/06 | Build 29996

Can someone please clear up my confusion and get me started
on the right path to success with VMware Server on FreeBSD,
or at least point me in the right direction for some decent
documentation that I can follow to a similar success?  Thanks!



William Bulley                     Email: web at

More information about the freebsd-emulation mailing list