freebsd 13 ryzen micro stutter

myfreeweb greg at
Tue Mar 23 09:34:45 UTC 2021

On March 23, 2021 9:11:46 AM UTC, Michael Gmelin <freebsd at> wrote:
>On Mon, 22 Mar 2021 23:50:52 -0400
>monochrome <monochrome at> wrote:
>> After about 8 months of struggling to narrow this down I did another 
>> search and saw this:
>> I haven't seen this come up here so I thought I would bring it up.
>> My story started sometime before around August last year when synergy 
>> started getting really annoying with stuttering. Pretty sure it
>> wasn't like that when I first started tracking 13-current in around
>> May 2020 (I was on 12 with scfb for a long time before that with no
>> issues), but since then I have tried to eliminate as many variables
>> as possible. First I switched to barrier instead of synergy. Shortly
>> after that I realized it was happening all the time and not just a
>> network problem, I started using foobillard to verify during tests. I
>> tried different RAM combinations, different network cards, a variety
>> of RAM timings, stripping rc.conf etc, powerd settings, also scfb,
>> with no effect. It is observable with ping -f, a dot or two appears
>> every time it glitches. It seemed much better with RC2, but now with
>> RC3 it seems to be back with a vengeance, and since its my main
>> workstation and barrier/synergy server host for several machines, it
>> is unbearable to use. Both Win10 and devuan3 on the same machine are
>> smooth with no issues. Any feedback or info would be appreciated.
>> Hardware:
>> ASRock B450M Pro4
>> Ryzen 2400G, no OC
>> 32M DDR4-2933
>> Onboard Vega GPU, drm-fbsd13-kmod
>> _______________________________________________
>Without knowing much about the issue at hand, just a few ideas:
>Sysctls I would look at:
>- raising *.cx_lowest
>- different kern.eventtimer.timer

None of these should be an issue, but:

sysctl kern.sched.steal_thresh=1

For some reason with the default value of 2, I'm seeing weird stuttering in youtube videos, games, etc. on a 5950X system. 1 (or 0, IIRC) works fine.

>Try running with powerd disabled.

well, if you do that, don't forget to manually set the freq sysctl to the maximum

More information about the freebsd-current mailing list