mtu setting in rc.conf

Dustin Marquess dmarquess at
Fri Apr 30 07:29:55 UTC 2021

I upgraded a 14-CURRENT system from a build about 2 months old to current.

In my /etc/rc.conf, I have:

cloned_interfaces="lagg0 lagg1 tap0 tap1 tap2 bridge0 bridge1 bridge2
vlan1 vlan2"
ifconfig_cxl0="txcsum txcsum6 lso mtu 9000 up"
ifconfig_cxl1="txcsum txcsum6 lso mtu 9000 up"
ifconfig_cxl2="txcsum txcsum6 lso mtu 9000 up"
ifconfig_cxl3="txcsum txcsum6 lso mtu 9000 up"
ifconfig_lagg0="laggproto lacp lagghash l3,l4 laggport cxl0 laggport
cxl1 laggport cxl2 laggport cxl3 txcsum txcsum6 lso mtu 9000"
ifconfig_tap2="mtu 9000"
ifconfig_bridge2="inet addm lagg0 addm tap2 mtu 9000"
ifconfig_bridge2_ipv6="inet6 2001:db8::101/64"
ifconfig_bridge2_alias0="inet netmask"
[ Other interfaces trimmed ]

This has worked for years.  Now, however, bridge2 & lagg0 aren't
getting the mtu 9000 setting, therefore tap2 isn't added to the bridge
at startup, and somehow the main IP on bridge2 isn't getting set
because of that.

Removing "addm tap2" from ifconfig_bridge2 allows everything to come
up, including the main IP, but lagg0 & bridge2 are still at mtu 1500.
Setting them to 9000 by hand and then adding tap2 by hand works.  I
tried moving the "mtu 9000" to the beginning of the line, but that
didn't seem to fix it.  Has something changed recently with this?


More information about the freebsd-current mailing list