acpi issues on FreeBSD-current_r350103 on Thinkpad A485

Evilham contact at evilham.com
Fri Jul 19 22:54:59 UTC 2019


Hey,

On ds., jul. 20 2019, Cristian Pogolsha wrote:

> I tried recently to boot FreeBSD current r350103 on a Thinkpad 
> A485. It's
> the AMD Ryzen equivalent of the T480. During the boot I 
> encountered this
> ACPI related error
> https://drive.google.com/file/d/1dzgSonn6Cuc1YrDeAUYSqHZlcmzaDY2Y/view

I have the same laptop and recently spent a fair amount of time 
getting it to work, I've been wanting to document this in a more 
proper fashion (e.g. FreeBSD's wiki) but haven't gotten the time, 
maybe since this will save you time, you would be able to put this 
and your own findings together and do that?
If not, at the very least people searching on the web will have 
now a better chance to find this email.

Note: I run on a daily basis, 12-RELEASE but I tested 13-CURRENT 
about a month ago and everything applied verbatim.


First things: in order to get the Thinkpad A485 to boot, wait 
until you see the logo and press 3 for boot options, once there 
type:

set hw.pci.mcfg=0
boot

It should work alright now, after installing the system, triple 
check that /boot/loader.conf contains this:

# Ryzen hack: FreeBSD bug #231760
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231760
hw.pci.mcfg=0

# Wireless Intel AC8265
# Not strictly necessary, but the Realtek that is shipped is not 
  supported
# You can easily (and carefully) change them.
if_iwm_load="YES"
iwm8265fw_load="YES"


Now, if you want X, you should install drm-kmod and add following 
to your /etc/rc.conf:
# Graphics
kld_list="amdgpu"


Those are the tricky bits to get the system to work IIRC (also: 
your ethernet is re1, not re0).

After this, the system should work fine (it even suspends and 
resumes back to X!), with minor glitches and a serious issue.
Take into account that I didn't research these too much because 
they are minor annoyances for me.

Minor glitches:
- xbacklight doesn't work, neither does intel-backlight because 
  it's AMD
- Speakers don't appear to work, audio input/output on 3.5 jack 
  does.
- SD card reader doesn't work (Bounty for 125 USD: 
  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204521)

Serious issue:
I was just debugging this right now, more infos with a proper bug 
report will come, but I think the system encounters a deadlock 
sometimes with the drm-kmod / amdgpu which results in a kernel 
panic.
It is a serious issue, but it allows me to use the computer for 
work, it doesn't happen every couple hours, but it does happen a 
couple times a day.

FWIW, this is part of the crashlog:

WARNING !drm_modeset_is_locked(&plane->mutex) failed at 
/wrkdirs/usr/ports/graphics/drm-fbsd12.0-kmod/work/kms-drm-6365030/drivers/gpu/drm/drm_atomic_helper.c:821
[Multiple times...]
kernel trap 22 with interrupts disabled
                            kernel trap 22 with interrupts 
                            disabled
kernel trap 22 with interrupts disabled
kernel trap 22 with interrupts disabled
    panic: spin lock held too long


> Sorry that I'm posting images instead of plain text. I have no 
> idea how to
> do kernel dumps during the bootload of a live image. I would be 
> happy to
> post more information if required, let me know how I can do it.

No worries, it took me forever to find the bug that had the 
sysctl.


I hope this helps you out,
--
Evilham


More information about the freebsd-current mailing list