efibootmgr: Cannot translate unix loader path xxx\xxx\xxx to UEFI: No error: 0

Warner Losh imp at bsdimp.com
Thu Dec 27 15:38:34 UTC 2018

On Dec 27, 2018 7:42 AM, "O. Hartmann" <ohartmann at walstatt.org> wrote:

Hash: SHA256

Am Thu, 27 Dec 2018 13:29:44 +0100
"Hartmann, O." <ohartmann at walstatt.org> schrieb:

> Updated Fujitsu Celsius M740 to its lates UEFI firmware today.
> After this update, the box won't boot FreeBSD 12-STABLE anymore! With
> disabled CSM, the firmware doesn't recognise the boot SSD's freebsd-efi
> partition for UEFI boot anymore - which was no problem before.
> When trying FreeBSD 13-CURRENT (USB image from 26.12.2018 as of the
> snapshot site) I receive a malloc arena error when trying to set boot
> vars via efibootmgr utility. So I tried the recent 12-STABLE snapshot
> as of 26th December 2018, the same as CURRENT USB Image, and I receive
> a weird error:
> efibootmgr -c -l /mnt/EFI/BOOT/BOOTX64.EFI -L FreeBSD
> efibootmgr: Cannot translate unix loader path
> '\mnt\EFI\BOOT\BOOTX64.EFI' to UEFI: No error: 0
> What the heck is that?
> What does this error mean? No error: 0?
> The box is unusable.
> Kind regards,
> O. Hartmann

I found this PR, Bug 229191, from June, 2018:


It seems the problem has not been fixed. Indeed did I mount the ESP
via a GEOM label, /dev/gpt/efiboot0.

There is some code that tries to cope, but I ran out of time before it was
bulletproof.  You can use nda0p9:/path/in/fs instead. Assuming the esp is
on /dev/nda0p9.


- --
O. Hartmann

Ich widerspreche der Nutzung oder Übermittlung meiner Daten für
Werbezwecke oder für die Markt- oder Meinungsforschung (§ 28 Abs. 4 BDSG).

freebsd-current at freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscribe at freebsd.org"

More information about the freebsd-current mailing list