r326820 stuck on bootloader

O. Hartmann ohartmann at walstatt.org
Mon Dec 18 16:17:08 UTC 2017

Am Mon, 18 Dec 2017 05:35:33 -0800 (PST)
"Rodney W. Grimes" <freebsd-rwg at pdx.rh.CN85.dnsmgr.net> schrieb:

> > Hey all!
> > 
> > I have just downloaded
> > FreeBSD-12.0-CURRENT-amd64-20171213-r326820-memstick.img.xz and
> > decompressed it, trying to boot it on QEMU and I get "Consoles:
> > internal video/keyboard" and then it's stuck.
> > 
> > I actually have no idea how to debug, any help would be appreciated.  
> This snapshot may have broken boot code in it, I had problems
> installing it to a zfs system and had to post install replace
> my zfs boot blocks from those of 20171206.
> > Thanks in advance,
> > - -- 
> > antranigv  

The shit hit the fan at > r326593 (this is what Warner wrote me back, I had no problems
with r326583, but r326584 and beyond had compilation issues). I tried r326593 and it
worked for me (had issues on a serial console for the PCengine APU2C4).

From usr/src/UPDATING, tag designated by "20171215":

        r326887 fixes the issue described in the 20171214 UPDATING entry.
        r326888 flips the switch back to building GELI support always.


I tried the first time r326888 on the APU 2C4 and it worked again - this doesn't imply
that the GPT GELI and ZFSBOOT loader are all right again, but Warner Losh stated it is

I'm with FreeBSD 12.0-CURRENT #16 r326911: Sat Dec 16 20:49:38 CET 2017 amd64 and it is
working well so far.

Kind regards,

O. Hartmann

Ich widerspreche der Nutzung oder Übermittlung meiner Daten für
Werbezwecke oder für die Markt- oder Meinungsforschung (§ 28 Abs. 4 BDSG).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 313 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freebsd.org/pipermail/freebsd-current/attachments/20171218/2df00f34/attachment.sig>

More information about the freebsd-current mailing list