Error attempting to link during buildworld

Pete Wright pete at
Sun Dec 3 16:36:55 UTC 2017

On 12/03/2017 00:27, Eitan Adler wrote:
> On 2 December 2017 at 17:45, Pete Wright <pete at> wrote:
>> i also am not seeing any reports of functions not being declared, although
>> i'm currently re-testing the build now with a single worker passed to make
>> so that i can get clearer output to validate this. i'm also going to try on
>> another box running current i have to see if this is just my laptop being
>> silly or if there is a real issue.
> Just ran into this though it went away after a 'svn up'.

i'm starting to suspect my current world must be in a broken state. i've 
tried a fresh checkout, same error.  then checked out the revision of my 
currently running world/kernel and get a similar linker error - which 
seems to indicate last time i updated my system something went bad with 
llvm/clang maybe?  now i just need to figure out how to get myself out 
of this whole i've apparently dug myself into :)


Pete Wright
pete at

More information about the freebsd-current mailing list