Recent seems to have broken toolchain

Steve Kargl sgk at
Tue May 31 16:43:12 UTC 2016

On Tue, May 31, 2016 at 10:25:54AM -0400, Ed Maste wrote:
> On 30 May 2016 at 15:51, Steve Kargl <sgk at> wrote:
> >
> > It happens with both /usr/bin/ld and /usr/local/bin/ld.  I remove the
> > binutils port and still had the issue.  I tried reverting recent changes
> > to elftoolchain/libelftc, the resulting tree would not build.
> The elftoolchain changes are a good candidate to check, although they
> should have no impact at all on the linker.
> What error did you encounter when trying to build with them reverted?

See my reply to dim at .  I don't remember the error message,
but it concerned a missing function with a cpp_ prefix.  I
just tried to reproduce the error and everything built as

I was hoping that you might have an 'Aha!' moment and know
where to look.  If I give gfortran48 the -Wl,--allow-multiple-definition
the code builds without issue.  So, it seems a compile-time
option for ld (or loader script) has been flipped.


More information about the freebsd-current mailing list