Recent seems to have broken toolchain

Steve Kargl sgk at
Tue May 31 16:36:52 UTC 2016

On Tue, May 31, 2016 at 06:21:06PM +0200, Dimitry Andric wrote:
> > 
> > The elftoolchain changes are a good candidate to check, although they
> > should have no impact at all on the linker.
> > 
> > What error did you encounter when trying to build with them reverted?

Ed is referring to a different an error after I tried revert
to a known good revision.

   190  9:20    cd /usr/src
   191  9:20    svn revert -R .
   192  9:21    cd contrib/elftoolchain/libelftc
   193  9:21    svn merge -r head:295577 .
   194  9:21    cd /usr/src/lib/libelftc
   197  9:22    svn merge -r head:295577 .
   198  9:22    make

This actually builds now.  Previously, I go an error about
a missing function (which I can't remember).

> > Yes, pointm.o is in both libtgt.a and liboa.a.  In the past, during
> > linking, the symbols are resolved from the first of -ltgt or -loa
> > depending on the order on the command line.
> Maybe elftoolchain's ar does something different?  Assuming the .a files
> are built with the system ar, of course.

I tried reverting ar to a previously known good revision.
That did not help.  I was hoping either you or Ed would have 
an 'Aha!' moment and recognize where to look in the source.

Unfortunately, the problem appears on the master node of
my small cluster, which in the middle of a fairly long
computation.  I won't be able to bisect the tree until
at least Friday. 


More information about the freebsd-current mailing list