EARLY_AP_STARTUP hangs during boot

John Baldwin jhb at freebsd.org
Mon May 16 18:44:36 UTC 2016

On Monday, May 16, 2016 12:22:42 PM Gary Jennejohn wrote:
> I tried out EARLY_AP_STARTUP, but the kernel hangs and I can't
> break into DDB.
> I did a verbose boot and the last lines I see are related to routing
> MSI-X to various local APIC vectors.  I copied the last few lines and
> they look like this:
> msi: routing MSI-X IRQ 256 to local APIC 2 vector 48
> msi: routing MSI-X IRQ 257 to local APIC 3 vector 48
> msi: routing MSI-X IRQ 258 to local APIC 4 vector 48
> msi: routing MSI-X IRQ 256 to local APIC 0 vector 49
> I tried disabling msi and msix in /boot/loader.conf, but the settings
> were ignored (probabaly too early).

No, those settings are not too early.  However, the routing to different
CPUs now happens earlier than it used to.  What is the line before the
MSI lines?  You can take a picture with your phone/camera if that's simplest.

> I'm running on a AMD Phenom(tm) II X6 1090T Processor.
> So, maybe this option only really works correctly on Intel CPUs?

No, there is absolutely zero/zilch/nada about this that is specific to
Intel CPUs.  Very, very little in FreeBSD is specific to AMD vs Intel
CPUs.  It is, OTOH, quite likely that this is specific to device driver
for a piece of hardware.

John Baldwin

More information about the freebsd-current mailing list