i915kms broken at some commit between r296485 and r297692?

Hans Petter Selasky hps at selasky.org
Mon May 9 16:07:42 UTC 2016

On 05/09/16 04:34, Sergey Manucharian wrote:
> I'm running FreeBSD 11.0-CURRENT r292595 on ThinkPad T430 (i7-3520M,
> Intel video 4000). Today I tried to update to a fresher version.
> Something has been broken somewhere between r296485 and r297692,
> I suspect namely i915kms - it won't boot: at the boot screen I see that
> all modules are loaded, then after "Booting..." message at the bottom
> screen turns black in 1-2 seconds of booting process, it seems to be the
> point when it regularly switches to native resolution.
> Can somebody shed light on it? What can I check to get more info on
> this?
> Regularly I update to the revisions used to build snapshots at:
> ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/ISO-IMAGES/11.0/
> assuming that those revisions have less issues. So tried a few, including
> the head. None worked for me after a certain revision (from the range I
> mentioned above).
> Thanks for advices!


I'm seeing the same thing with a MacBookPro. When loading drm2 and i915 
after boot, it works. I think it is something simple causing this failure.


More information about the freebsd-current mailing list