FreeBSD 11.0-RC1 boot prompt kernel load issue.

Murthy Bhat murthy.bhat at
Wed Aug 24 15:07:06 UTC 2016


This is regarding issue faced during OS(FreeBSD 11.0-RC1) installation on the storage behind our smartpqi storage controller.

System used: HP ProLiant ML110 gen9
The iso image downloaded is FreeBSD-11.0-RC1-amd64-disc1 from

To achieve the OS installation on storage behind our storage controller, we have built 2 binaries.

1)     Customized rebuilt kernel by disabling aac modules in /usr/src/sys/amd64/conf/GENERIC file. The size of the kernel is around 26MB. Even we tried a smaller sized kernel by disabling unwanted modules.

2)     smartpqi driver compiled for this kernel

During our customized kernel load, there is a system crash and restart(step 5.e below) in the following steps.

1) Copy the driver module ( smartpqi.ko ) & customized kernel in the USB Pen drive.

2) Connect the CD/DVD drive, USB which contains driver module & kernel and the hard drive that is connected to the SmartPQI controller.

3) Insert the FreeBSD Installation disk into CD/DVD drive & boot from it.

4) At FreeBSD boot menu press Escape for boot loader prompt.

5) Perform the following steps at boot loader prompt.

               a) See all present modules by executing following command.
                              # lsmod
                              Expected Output: It will show all the present modules.

               b) unload the kernel module
                              # unload

               c) Check kernel is unloaded or not
                              # lsmod
                              Expected Output: It will not show any module.

               d) Check whether USB drive detected or not.
                              # lsdev
                              Expected Output:
                              part 0: .............. (removable)
                              part 1: .............. (removable)
                              part 2: .............. (removable)

               e) Load the kernel (This is the rebuilt kernel by disabling our other Adaptec aac drivers)
                              # load part< pen drive location >:kernel             ==> text is loaded, during data load, there is a crash and system reboot.
                              # load part2:kernel

               f) Load the driver module
                              # load part< pen drive location >:smartpqi.ko
                              # load part2:smartpqi.ko

               g) Continue the Installation procedure, type the following command & Enter.
                              # boot

6) Install the FreeBSD OS including the kernel source. It is very important to include kernel source.

Please help to resolve this crash issue and thanks in advance.

PS: Even with the original kernel i.e kernel without GENERIC conf modification, the "load partx:kernel" crashes. The same is working in FreeBSD 10.2 and 10.3.

Also if possible please let us know how to blacklist modules during OS installation in FreeBSD. Say to blacklist/block "aac" modules what is the step followed at boot prompt. We tried "set hint.XXX.0.disable=1" etc in boot prompt  but no luck.


More information about the freebsd-current mailing list