kern.proc.pathname failure while booting from zfs

Frederic Chardon chardon.frederic at
Tue Aug 23 07:27:58 UTC 2016

Le 20 août 2016 22:03, "Frederic Chardon" <chardon.frederic at> a
écrit :
> Hi
> I see a strange interaction between zfs on root and kern.proc.pathname
> on my laptop. Whenever I try to use gcore it fails with:
> gcore 1023
> gcore: kern.proc.pathname failure
> However, gcore /usr/local/bin/zsh 1023 is working properly.
> I made some tests booting from usb stick (fresh installworld, no
> src.conf, no make.conf, GENERIC kernel)
> What works: having / on ufs and importing a zfs pool later on.
> What doesn't: having / on zfs, whatever the settings for checksum,
> compression, or normalization.
> Both 11-stable and 12-current behave this way. Current from may-june
> worked properly.
> adb, chromium and virtualbox as well stopped working at approximately
> the same time, however I don't know if it is linked ("truss -f adb
> start-server" shows that garbage is passed to execl after forking).
> Any idea what's going on? Does anybody else see this?
> Thanks!

Nobody else have this problem? I reinstalled the system from scratch and
still gcore fails with the same error, even in single user mode.

More information about the freebsd-current mailing list