10.03 to -current software removal

Joshua Rogers megamansec at gmail.com
Mon Aug 22 18:55:35 UTC 2016

Hi everybody,

I've come across a problem when upgrading from 10.03 to -current, which
I needed to do since my graphics driver isn't supported in 10.03, after

When I built the world and kernel, and did `make installkernel',
everything was perfect; I rebooted, and xorg ran, my wm was perfect,
software worked, and I could even change the backlight of my screen
using redshift.

However, when I went to the next step, `make installworld', and `yes |
make delete-old ; yes | make delete-old-libs', and I rebooted, xorg had
been uninstalled, along with many other things such as firefox, etc. It
was an easy fix to just reinstall them, however.

The problem is, after booting and starting xorg and everything, I've
come across a few errors when running software:

libreoffice and transmission-gtk no longer run(and probably other software):
/usr/local/lib/libreoffice/program/oosplash: Undefined symbol "dirname"
/usr/local/bin/transmission-gtk: Undefined symbol "dirname"
and redshift no longer can change the backlight color at all(manually
using xgamma doesn't work, either.)

vlc is also very laggy when fullscreen.

I suspect a library has been uninstalled or something along those lines
when I ran the last step as mentioned.

Does anybody know the best course of action to either: work out which
software was uninstalled so I can reinstall it, or to debug the specific
issues I'm having?


More information about the freebsd-current mailing list