Mosh regression between 10.x and 11-stable

Peter Jeremy peter at
Wed Aug 10 08:18:51 UTC 2016

I recently updated one of my VPS hosts from 10.3-RELEASE-p5 to 11.0-BETA4
r303811 and mosh to that host from my Linux laptop stopped working.  All
I get on the laptop is:
$ mosh remotehost
Connection to remotehost closed.
/usr/bin/mosh: Did not find mosh server startup message.

I've tried rebuilding mosh (and all dependencies) on the host to no avail.

This isn't the DSA change that's been discussed elsewhere: I can SSH from my
laptop to the host without problem.  I can also manually invoke mosh-client
and mosh-server and it works.  Unfortunately, mosh has no provision for
debugging.  I've tried hacking the mosh perl script to make it more verbose
and that shows that:
1) the "MOSH CONNECT" message isn't making it out of the local ssh process.
2) it's racy because I can get it from "always fails" to "sometimes works".

My suspicion is that something has changed in either sshd or TCP that
is resulting in the connection going away before the stdout from the
remote mosh-server makes it out from the local ssh process.

I've looked at tcpdump's of both successful and failed SSH sessions
but don't see anything obviously different (encryption makes it
difficult to decode the session).

Has anyone else seen this behaviour or have any ideas what might be
causing it?

Peter Jeremy
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 949 bytes
Desc: not available
URL: <>

More information about the freebsd-current mailing list