T40 bootloop on CAM status: Command timeout on both 10.1 and -CURRENT

bsdml pietro.bsdml at gmail.com
Mon Mar 30 18:07:52 UTC 2015

Hello Kevin,

thanks for your clarification. Unfortunately I wasn't aware that the T40 
and *4's line used a SATA-PATA convertor and especially that was going 
to clash with the new ATA stack in FreeBSD. Either OpenBSD and NetBSD do 
work out of the box without any hassle, however I'd still prefer to use 
FreeBSD on it as I have been using FreeBSD for about 8 years now and I 
am very comfortable with it.

The question at this point is, is there any hope to see this issue 
resolved in the future? Or will I have to give up to the second ATA 
channel in order to use FreeBSD?

Pietro Sammarco

On 30/03/2015 06:17, Kevin Oberman wrote:
> On Sun, Mar 29, 2015 at 2:27 AM, Wolfgang Zenker 
> <wolfgang at lyxys.ka.sub.org <mailto:wolfgang at lyxys.ka.sub.org>> wrote:
>     Hi,
>     * bsdml <pietro.bsdml at gmail.com <mailto:pietro.bsdml at gmail.com>>
>     [150329 01:34]:
>     > since I tried to install FreeBSD 10.1 on my recently purchased T40 I got
>     > stuck at this annoying bootloop that says
>     > "ATAPY_IDENTIFY. ACB: a1 00 00 00 00 40 00 00 00 etc etc.. CAM
>     status:
>     > Command timeout". I have also tried latest 11-CURRENT snapshot
>     and it
>     > did not make any difference at all, it is affected from the same
>     exact
>     > bootloop.
>     > [..]
>     > It seems like there might be an issue with the CAM ATA stack that is
>     > clashing with the PATA controller on my T40.
>     I had the same problem on an ancient T42p. In my case, disabling the
>     second ata channel allowed me to boot.
>     I added the following line to /boot/device.hints:
>     hint.ata.1.disabled="1"
> This is an annoying side-effect of the brain-dead SATA-PATA converter 
> in that generation of ThinkPads. The Intel ICH6 chipset is SATA, but, 
> for reasons known ot IBM/Lenovo, the systems used PATA drives! So they 
> has a SATA-PATA converter built in that screwed up a LOT of things, 
> mostly compromising performance and generating assorted log entries. 
> Looks like that also is broken in modern ATA support if a drive is not 
> present.
> This was always my biggest complaint with this laptop (T42) which I 
> used for several years until I retired and returned to so it could be 
> excessed legally as it was government property (and, I didn't really 
> want it, even if I could have kept it). Not an awful system, but this 
> one issue was really annoying to me.
> --
> Kevin Oberman, Network Engineer, Retired
> E-mail: rkoberman at gmail.com <mailto:rkoberman at gmail.com>

More information about the freebsd-current mailing list