T40 bootloop on CAM status: Command timeout on both 10.1 and -CURRENT

bsdml pietro.bsdml at gmail.com
Mon Mar 30 17:38:57 UTC 2015

Hey wolfgang,

thanks for getting back to me. Adding hint.ata.1.disabled="1" in 
/boot/device.hints indeed did the trick and allowed me to boot both 10.1 
and 11-CURRENT, however this workaround has temporary solved my problem 
but brings up to another headache. I have planned to get a bay caddy and 
swap the cdrom drive with a 7.200 rpm SATA hdd, but doing this way 
disabling the second SATA channel I will be unable to achieve such a thing.

Is there a chance that the bay caddy ATA will work without the need to 
disable the second ATA channel?

Pietro Sammarco

On 29/03/2015 11:27, Wolfgang Zenker wrote:
> Hi,
> * bsdml <pietro.bsdml at gmail.com> [150329 01:34]:
>> since I tried to install FreeBSD 10.1 on my recently purchased T40 I got
>> stuck at this annoying bootloop that says
>> "ATAPY_IDENTIFY. ACB: a1 00 00 00 00 40 00 00 00 etc etc.. CAM status:
>> Command timeout". I have also tried latest 11-CURRENT snapshot and it
>> did not make any difference at all, it is affected from the same exact
>> bootloop.
>> [..]
>> It seems like there might be an issue with the CAM ATA stack that is
>> clashing with the PATA controller on my T40.
> I had the same problem on an ancient T42p. In my case, disabling the
> second ata channel allowed me to boot.
> I added the following line to /boot/device.hints:
> hint.ata.1.disabled="1"
> Wolfgang

More information about the freebsd-current mailing list