cant use Xorg after r277486 on Asus Zenbook

Stefan Parvu sparvu at
Fri Mar 20 12:33:05 UTC 2015


Im currently running 11.0-CURRENT #0 r277486 on Asus Zenbook laptop [1].

Im happy, there are some issues with iwn driver but it does work enough stable.
Xorg, Sound, Networking functional. Even power management works enough
decent to get 3hrs or so without a power adapter connected.

Now I have discovered Im not able to update to any new snapshots after
r277486. Xorg refuses to work, Im getting a blank screen with no possibility to
have a functional vt restoration. I always need to reboot. The kernel is up
I can use the keyboard so the only trouble seems to come from Xorg / vt.

I have tried updating my laptop to: r278452, r278908, r279514, r279813.
No luck.  If I go back to use r277486 then my Xorg and vt start functioning 
correctly. Im using the i915 driver for Xorg and my config is in [1]. 

Any ideas what is this about ? Were any changes after r277486 regarding 
i915 or Xorg ? I tried to create a new xorg.conf, reuse the old one whatever.
No luck.

Many thanks,

Stefan Parvu <sparvu at>

[1] -

More information about the freebsd-current mailing list