pkg 1.4 freeze please test test test!

Don Lewis truckman at
Thu Oct 30 04:00:59 UTC 2014

On 29 Oct, Baptiste Daroussin wrote:
> On Wed, Oct 29, 2014 at 01:15:16PM -0700, Don Lewis wrote:
>> On 28 Oct, Don Lewis wrote:
>> > On 29 Oct, Baptiste Daroussin wrote:
>> >> Hi all,
>> >> 
>> >> We are starting the release process of pkg 1.4, we want to have a better release
>> >> process than with every single previous version of pkg. For that we will need
>> >> you help!
>> >> 
>> >> pkg-devel has been updated to the latest version of pkg as of alpha2.
>> >> 
>> >> Changes you can expect in pkg 1.4 are the following:
>> >> - Loads of bug fixes
>> > 
>> > I kind of doubt that I'll have time to test it, but I've stumbled across
>> > an interesting test case for package building with pkg-1.3.8_3.
>> > 
>> > When I tried to build a multimedia/2mandvd package with
>> > poudriere (either bulk or testport) in a FreeBSD 10 amd64 host and jail,
>> > pkg-static segfaults.  Portsmon also sees this failure, which also
>> > seems to be affecting head/amd64 as well:
>> > <>
>> > 
>> > If I run poudriere jail -i to keep the jail around, I don't see any
>> > leftover core files, I'm guessing because pkg-static's cwd is in the r/o
>> > /usr/ports tree.  If I then cd /usr/ports/multimedia/2mandvd in the
>> > jail and run:
>> > 	make clean
>> > 	make stage
>> > 	make package
>> > pkg-static doesn't segfault, but it never exits either.  I left it
>> > running for a couple of days and it was still stuck at 100% CPU.  If
>> > I truss -p the process, I don't get any output, which means it's not
>> > doing any syscalls.
>> I found some time to test this version.  I added WITH_PKG=devel to the
>> make.conf file for the poudriere jail and ran:
>> 	poudriere testport -j 101STABLEamd64 -o multimedia/2mandvd
> Ah crap this 2mandvd again.....
> Ok I'll track it down, thanks

Seems to work fine on 8.4, both i386 and amd64, so it appears to be
sensitive to something in base.

> 2mandvd is a nightmare for me :)

Back when I was still using portupgrade to build packages, I didn't have
trouble building the package, but portupgrade would fail during the
deinstall phase for 2mandvd.  I think it was complaining about non-ASCII
characters in the plist, but I don't know where the error was coming
from.  I didn't have trouble manually doing the deinstall with pkg
delete, and then I could run portupgrade -Np.  I didn't think of trying
pkg-static to see if it behaved differently.

More information about the freebsd-current mailing list