Mounting ZFS with error 5 failed, since r271963 callout convert

Michael Schmiedgen schmiedgen at
Mon Oct 27 22:46:27 UTC 2014

On 10/27/2014 22:29, Ryan Stone wrote:
> On Mon, Oct 27, 2014 at 4:21 PM, Michael Schmiedgen <schmiedgen at> wrote:
>> Hi List,
>> my ZFS does not mount. I bifurcated to r271963 that
>> does not work anymore. The commit seems not directly
>> related to ZFS, but is rather a conversion from timeout(9)
>> to callout(9).
>> After booting the kernel it drops to the mount prompt,
>> stating that ZFS cannot be mounted because of 'error 5'.
>> Any hints? Can I provide some more information?
>> Thanks,
>>    Michael
> The changes to the 3 files there look to be independent, so can you
> narrow this down further by applying the patch to only a single file?
> Of those three only ACPI looks like it could affect ZFS or disks, so
> this will be the patch to try first:
> If you can get a verbose boot log from the machine that would be
> helpful, but you'd need a serial console to capture that.

I applied first acpi.c, then atkbd.c and at last kern_cons.c that
triggered the error.

In previous months I had already the same problem with ZFS if
nvidia driver was loaded via /boot/loader.conf. It triggered
the same error. So I loaded the driver on demand with kldload
after login and everything (X + stuff) worked fine.

Very strange...

Does anyone have a clue what is going on here?


More information about the freebsd-current mailing list