emulators/virtualbox-ose: compilation on CURRENT fails due to: tstVMStructRC: 1: Syntax error: "(" unexpected

O. Hartmann ohartman at zedat.fu-berlin.de
Mon Oct 27 13:12:37 UTC 2014

Compiling emulators/virtualbox-ose on a freshly installed CURRENT
(FreeBSD 11.0-CURRENT #0 r273719: Mon Oct 27 07:59:12 CET 2014 amd64)
results in the below shown error.

I also tried to install the package on CURRENT via pkg install, but
this results in a 32-Bit VirtualBox only - which is inacceptable.

I have running emulators/virtualbox-ose on several other CURRENT
machines, but most of those boxes are "grown", that means, they got
CURRENT months ago and are maintained as usual (buildworld/portmaster).
This box has been installed a couple of weeks ago and is successfully
rejecting compilation of port emulators/virtualbox-ose, although I
already updated the ports tree and did successfully a portmaster -R
-fd /emulators/virtualbox-ose.

Since I use some non-standard optimization flags in /etc/src.conf
and /etc/make.conf (-O3 and CPUTYPE=native instead of plain -O and
outdated architectural compatibilities), I switched back to the FreeBSD
vanilla standard - but still the same. I can not imagine that the CPU
of that specific box could be the culprit:

dmesg output:

CPU: Intel(R) Core(TM)
i5-3470 CPU @ 3.20GHz (3192.82-MHz K8-class CPU) Origin="GenuineIntel"
Id=0x306a9  Family=0x6  Model=0x3a  Stepping=9
AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM> AMD Features2=0x1<LAHF>
  Structured Extended Features=0x281<FSGSBASE,SMEP,ERMS>
  XSAVE Features=0x1<XSAVEOPT>
  TSC: P-state invariant, performance statistics
real memory  = 9107931136 (8686 MB)
avail memory = 8147902464 (7770 MB)

I have also problems compiling the port on a newly setup laptop (Intel
i5-4200M CPU/Haswell), CURRENT as of the same date as reported here.
The failure is the same. It seems, that on CURRENT installations as of
a certain date not far in the past, the port fails to recompile

The error is:


kBuild: Generating tstVMStructSize
- /usr/ports/emulators/virtualbox-ose/work/VirtualBox-4.3.18/out/freebsd.amd64/release/obj/VMM/tstVMStructRC.h /usr/ports/emulators/virtualbox-ose/work/VirtualBox-4.3.18/out/freebsd.amd64/release/bin/tstVMStructRC:
1: Syntax error: "(" unexpected kmk: ***
Error 2 kmk: *** Deleting file
kmk: *** Waiting for unfinished jobs.... filesplitter: Out of 144
files: 144 rewritten, 0 unchanged.
kmk: *** Exiting with status 2 *** Error code 2

More information about the freebsd-current mailing list