mkimg used to create gpt image, problem booting

Craig Rodrigues rodrigc at
Sat Aug 23 20:49:52 UTC 2014

On Sat, Aug 23, 2014 at 12:11 PM, Marcel Moolenaar <marcel at> wrote:
> Could be. Try the -P option to mkimg. It sets the
> underlying (unexposed) physical sector size while
> still working with the visible 512 bytes sectors.
> The net effect is that for the GPT scheme things
> get aligned to the physical sector size and that
> it also causes the image size to be rounded.
> You can also try emitting vmdk directly to see if
> that makes a difference. vmdk also has the side-
> effect of rounding the image to the grain size.

I tried the following experiments:

mkimg -v -f vmdk -s gpt -b test1/boot/pmbr -p
freebsd-boot:=test1/boot/gptboot -p freebsd-ufs:=/tmp/file.img -o

When I tried to boot the image in QEMU, I had the same problem as before.
It looks like it started writing the image on block 3, same as before.

I also tried adding the -P flag, with different values like 2048 and 4096.
I ran into the same problem.



More information about the freebsd-current mailing list