nscd not caching

Daniel Braniss danny at cs.huji.ac.il
Tue Aug 19 11:55:00 UTC 2014

On Aug 18, 2014, at 10:42 AM, Eggert, Lars <lars at netapp.com> wrote:

> Hi,
> On 2014-8-17, at 18:10, Adam McDougall <mcdouga9 at egr.msu.edu> wrote:
>> We were using +::::::::: type entries in the local password and group
>> tables and I believe we used an unmodified /etc/nsswitch.conf (excluding
>> cache lines while testing nscd):
> I tried that setup too, and it doesn't seem to be caching any NIS lookups either.
> The current NIS server is 25ms away, which is a pain. I'm trying to get a local slave set up, which will make the need for nscd go away, but it would sure be nice if it worked in the meantime.
>> At our site, we never had enough load to outright require nscd on
>> FreeBSD, although there were some areas where caching had a usability
>> benefit.
> Load is not an issue, latency is (see above).

I know that this a bit late but have you ever considered Hesiod? it uses DNS/txt.
we have been using it since the days when BSDi had no NIS support and haven’t
seen a ypserver not responding since :-)


More information about the freebsd-current mailing list