nscd not caching

Eggert, Lars lars at netapp.com
Mon Aug 18 07:43:36 UTC 2014


On 2014-8-17, at 18:10, Adam McDougall <mcdouga9 at egr.msu.edu> wrote:
> We were using +::::::::: type entries in the local password and group
> tables and I believe we used an unmodified /etc/nsswitch.conf (excluding
> cache lines while testing nscd):

I tried that setup too, and it doesn't seem to be caching any NIS lookups either.

The current NIS server is 25ms away, which is a pain. I'm trying to get a local slave set up, which will make the need for nscd go away, but it would sure be nice if it worked in the meantime.

> At our site, we never had enough load to outright require nscd on
> FreeBSD, although there were some areas where caching had a usability
> benefit.

Load is not an issue, latency is (see above).

>  top was slow to open since it would load the whole passwd
> table first, but top -u was a workaround.

Right, I see that issue too.

> As a workaround until we retired NIS, I wrote a hack of a script to
> merge NIS groups into my local /etc/group files periodically from cron.
> Aside from bugs in my script, that worked well.

I may end up doing this, too.

Given all this, maybe it's time to retire nscd?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 273 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.freebsd.org/pipermail/freebsd-current/attachments/20140818/75d5b2f3/attachment.sig>

More information about the freebsd-current mailing list