Problems with zpool upgrade embedded_data, and rebooting

Daniel Peyrolon tuchalia at
Fri Aug 8 22:41:03 UTC 2014

Hello everyone,

I just would like to gratuitously rant about something that happened on my

Basically, I upgraded my zpool to use embedded_data, since it would be more
efficient, and rebooted. (I installed the system with zfs using bsdinstall).
It turned out that gptzfsboot wasn't able to load that filesystem, so I
tried to get it working from a live system that I have on a USB drive.
It didn't work on that particular live system, but, fortunately, someone
could do me a favor and download the latest snapshot, and burn it to my USB

>From there, it was a matter of importing zroot, mounting it at /mnt, and
taking a look at the code of bsdinstall, trying to find the actual command
to update the bootloader.
I could manage to find it, and hopefully, everything worked again. Thanks
to those who helped me :)

What would be the better way to avoid this happening in the future?


More information about the freebsd-current mailing list