panic: aatpic_assign_cpu: bad cookie [Was: Build machine OK; laptop panics @r269515]

Michael Butler imb at
Tue Aug 5 20:56:47 UTC 2014

On 08/05/14 16:02, John Baldwin wrote:

> My guess is that the recent Xen changes tickled something.

I can confirm this on a kernel which is otherwise up to date ..

11.0-CURRENT #2 r269608M: Tue Aug  5 16:48:12 EDT 2014

I backed out all of SVN r269507 through r269515.

Now working ..

ada0: <Hitachi HTS725050A9A364 PC4OC70E> ATA-8 SATA 2.x device
ada0: Serial Number 101105PCK404VLKU1WXJ
ada0: 150.000MB/s transfers (SATA 1.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 476940MB (976773168 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4
battery0: battery initialization done, tried 1 times
acpi_acad0: On Line
acpi_acad0: acline initialization done, tried 1 times
SMP: AP CPU #1 Launched!
cpu1 AP:
     ID: 0x01000000   VER: 0x00050014 LDR: 0x00000000 DFR: 0xffffffff
  lint0: 0x00010700 lint1: 0x00000400 TPR: 0x00000000 SVR: 0x000001ff
  timer: 0x000100ef therm: 0x00010200 err: 0x000000f0 pmc: 0x00010400
ioapic0: routing intpin 1 (ISA IRQ 1) to lapic 1 vector 48
ioapic0: routing intpin 12 (ISA IRQ 12) to lapic 1 vector 49
ioapic0: routing intpin 17 (PCI IRQ 17) to lapic 1 vector 50
ioapic0: routing intpin 19 (PCI IRQ 19) to lapic 1 vector 51
msi: Assigning MSI IRQ 256 to local APIC 1 vector 52
hwpmc: SOFT/16/64/0x67<INT,USR,SYS,REA,WRI> TSC/1/64/0x20<REA>
SMP: passed TSC synchronization test
Timecounter "TSC" frequency 1662536220 Hz quality 1000
Root mount waiting for: usbus4

Now to see if it's related to the other machine's disk woes (it's a
single-core device),


More information about the freebsd-current mailing list