network.subr (r252360) changes break ifconfig_aliasX

Ian FREISLICH ianf at
Sun Jun 30 08:19:58 UTC 2013


I can't figure out how to use rc.conf to configure my interfaces
after these recent charges.  My use case is that I have interfaces
to configure but I don't need to put an IP address on them.  I do
need to change the MAC address though.

What I have been doing is probably wrong, but it worked up until

lagg0: link state changed to DOWN
/etc/rc: WARNING: $ifconfig_lagg0_alias0 needs  "inet" keyword for an IPv4 address.
ifconfig: ether: bad value

But, there is no ip address for this interface.

The config looks like:

cloned_interfaces="lagg0 \
        vlan2 vlan3 vlan4 vlan5 vlan6 vlan7 vlan8 vlan9 vlan14 vlan15 vlan19 \
        vlan20 vlan21 vlan22 vlan23 vlan24 vlan25 vlan26 vlan27 vlan30 \
        vlan33 vlan37 vlan39 vlan40 vlan41 vlan44 vlan45 vlan999 \

ifconfig_lagg0="up laggproto lacp laggport igb0 laggport igb1 laggport igb2 laggport igb3"
ifconfig_lagg0_alias0="ether 00:1e:c9:53:3e:15"

# Neotel
ifconfig_vlan2="vlandev lagg0 vlan 2" #should probably be create_args
ifconfig_vlan2_alias3="inet vhid 2 pass XXXXXXX advskew 20"
ifconfig_vlan2_alias4="inet vhid 2 pass XXXXXXX advskew 20"
ifconfig_vlan2_alias5="inet vhid 2 pass XXXXXXX advskew 20"


I've tried create_args but I still get the following error:

ifconfig: ether: bad value

and, I cannot use ifconfig_lagg0 to set the MAC address because the
rc system just seems to ignore the configured string.

I can however 'ifconfig lagg0 ether 00:1e:c9:53:3e:15' from the
cammand line, so there's something in the rc scripts that's mangling
the argument.


Ian Freislich

More information about the freebsd-current mailing list