Cannot startx on FreeBSD10 Current

Walter Hurry walterhurry at
Fri Jun 14 20:51:17 UTC 2013

On Fri, 14 Jun 2013 09:33:48 -0700, Craig Rodrigues wrote:

> On Fri, Jun 14, 2013 at 7:42 AM, Walter Hurry <walterhurry at>
> wrote:
>> I'm running FreeBSD 10.0-CURRENT (r251572) amd64 in a VirtualBox VM.
>  Recently, I started mentoring a Google Summer of Code student for the
> FreeBSD project.
> I worked with the student to set up a VM to run FreeBSD, with full
> graphical desktop.
> You might want to follow the instructions that the student followed
> here:
> Only interesting details:
>   (1)  Student used VMWare player instead of VirtualBox  (shouldn't be a
> big deal).
>   (2)  We used pkgng to install binary packages (3)  We used one of the
>   pkgng mirrors, since pkgng packages from
> aren't fully available yet
> Other than that, things worked fine, and the student was able to get a
> full FreeBSD with graphical desktop inside a VM.

Thanks for the pointer to the blog.

With hindsight, it seems that your student avoided the issue I ran into 
by installing precompiled binaries, whereas I was using the Ports 

The problem was the Clang miscompilation of xorg-server, as pointed out 
so kindly by Jung-uk Kim.

More information about the freebsd-current mailing list