USB Keyboard not worked on current (r251681)

Hans Petter Selasky hps at bitfrost.no
Fri Jun 14 09:31:58 UTC 2013


On 06/14/13 10:50, Vitalij Satanivskij wrote:
> Hello
>
> There is system -
>
> CPU: Intel(R) Xeon(R) CPU E5-2609 0 @ 2.40GHz (2400.05-MHz K8-class CPU)
> real memory  = 137438953472 (131072 MB)
> avail memory = 132517056512 (126378 MB)
>
> motherboard - X9DR3-F
>
> Keyboard is
>
> Logitech, identified as
>
> ugen1.2: <LITEON Technology> at usbus1
> ukbd0: <LITEON Technology USB Multimedia Keyboard, class 0/0, rev 1.10/1.01, addr 2> on usbus1
> kbd2 at ukbd0
> kbd2: ukbd0, generic (0), config:0x0, flags:0x3d0000
>
>
> Messages from dmesg (with "-v" in boot.conf )
>
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test kernel: usbd_setup_device_desc: getting device descriptor at addr 2 failed, USB_ERR_NOMEM
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test kernel: usbd_setup_device_desc: getting device descriptor at addr 2 failed, USB_ERR_NOMEM
> Jan  1 03:21:31 fmst-test kernel: Root mount waiting for: usbus1 usbus0
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test kernel: usbd_req_re_enumerate: addr=2, set address failed! (USB_ERR_NOMEM, ignored)
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test kernel: usbd_req_re_enumerate: addr=2, set address failed! (USB_ERR_NOMEM, ignored)
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test last message repeated 4 times
> Jan  1 03:21:31 fmst-test kernel: Root mount waiting for: usbus1 usbus0
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test last message repeated 8 times
>
> and at the end -
>
> Jan  1 03:21:31 fmst-test last message repeated 2 times
> Jan  1 03:21:31 fmst-test kernel: usbd_setup_device_desc: getting device descriptor at addr 2 failed, USB_ERR_NOMEM
> Jan  1 03:21:31 fmst-test kernel: ugen0.2: <Unknown> at usbus0 (disconnected)
> Jan  1 03:21:31 fmst-test kernel: uhub_reattach_port: could not allocate new device
> Jan  1 03:21:31 fmst-test kernel: usbd_ctrl_transfer_setup: could not setup default USB transfer
> Jan  1 03:21:31 fmst-test kernel: usbd_setup_device_desc: getting device descriptor at addr 2 failed, USB_ERR_NOMEM
> Jan  1 03:21:31 fmst-test kernel: ugen1.2: <Unknown> at usbus1 (disconnected)
> Jan  1 03:21:31 fmst-test kernel: uhub_reattach_port: could not allocate new device
>
>
>
> I see thread's about same problem early, but patch alredy in head and no changes.
>
> What and how can i debug to see where is problem?

Hi,

Search for similar thread on -current mailing list. This is a known issue.

Thank you.

--HPS


More information about the freebsd-current mailing list