Memstick Images not working (mountroot prompt)

miguelmclara at miguelmclara at
Wed Jun 5 18:42:11 UTC 2013

Sadly it doesn't... Just two ports in the back and in the same controller. 

Its an Intel Panter Point controller, but I'll add that info to the PR as soon has my girlfriend get out of farmville and let's me use her laptop xD 

Note: I also tried "sysctl hw.xhci.xhci_port_route=-1" and =1 has I wasn't sure what would be correct but none of those helped!

Enviado a partir do meu smartphone BlackBerry®

-----Original Message-----
From: Glen Barber <gjb at>
Date: Wed, 5 Jun 2013 14:08:00 
To: Miguel Clara<miguelmclara at>
Cc: <freebsd-current at>
Subject: Re: Memstick Images not working (mountroot prompt)

On Wed, Jun 05, 2013 at 03:52:44PM +0100, Miguel Clara wrote:
> Forgot to CC the list, sorry!
> In the meantime I upgrade from 9.1 using the base and kernel tarballs,
> I could boot and I have wireless supported!
> I have my ssd encrypted and the hdd too, the hdd is encrypted with
> passphrase + key, and this key is in a usb stick (a different one form
> the other two already tried).
> The USB stick is not working to, and I also tried a USB Western
> Digital 500GB disk, no luck either!
> So no usb support basically...
> dmesg output after connecting the device:
> xhci_do_comand: Command timeout!
> usb_alloc_device: device init 2 failed (USB_ERR_TIMEOUT, ignored)
> usbgen0.2: <Unknown> at usbus0 (disconnected)
> usb_reattach_port: could not allocate new device
> Also note that usbus0 is a 3.0 as dmesg shows after boot:
> usbus0: waiting for BIOS to give up control
> usbus0 on xhci0
> usbus0: 5.0Gpbs Super Speed USB v 3.0
> ....
> So I guess this is indeed a problem in the 10.0-current kernel, not
> sure what it could be or what more can I do to debug though...
> Please advice,

Hmm.  Can you please try with a USB 2.0 port on the laptop?  (Hopefully
it has at least one non-USB-3.0 port...)


More information about the freebsd-current mailing list