kostikbel at gmail.com
Sat Feb 2 14:50:18 UTC 2013
On Sat, Feb 02, 2013 at 01:50:40PM +0200, Andriy Gapon wrote:
> I would like to propose the following mostly cosmetic change:
> This is something that bit me early in my FreeBSD days, so I am kind of obsessed
> with it.
> The current naming is confusing/misleading indeed.
> And magic properties of SI_SUB_RUN_SCHEDULER:SI_ORDER_LAST is a "hidden gem".
You may remove the Giant unlock from the scheduler()/swapper() as well
then, doing it before the swapper() call in the mi_startup().
Note that the wait chain for the idle swapper is still called "sched".
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 834 bytes
Desc: not available
More information about the freebsd-current