strange buildworld failure

Nikos Vassiliadis nvass at
Sat Nov 24 15:48:58 UTC 2012

On 11/24/2012 1:45 PM, Dimitry Andric wrote:
> On 2012-11-24 03:38, Benjamin Kaduk wrote:
>> On Fri, 23 Nov 2012, Nikos Vassiliadis wrote:
>>> On 11/23/2012 1:34 PM, Sergey Kandaurov wrote:
>>>>> Also, my src.conf had WITHOUT_CLANG but I deleted it and then I
>>>>> also deleted /usr/obj when it failed for the first time. But that
>>>>> didn't work. I am building with -j3.
>>>> Does it always fail there at usr.bin/ypwhich?
>>>> It's likely that -j3 is the culprit of why you do not see the actual build
>>>> error because it might be lost off the screen. Try to restart without -jN.
>>> Thanks, that worked.
>> Hmm, buildworld is supposed to be parallel-make-safe.
>> Perhaps a full log of the failing buildworld (e.g., with script(1)) could
>> be posted for analysis?
> Well, either a full log, or the tail of the log, as long as it contains
> the actual command(s) that failed.  Sometimes it can help to search
> backwards with less, or your favorite editor, for the string "error:",
> or if there is no such string, searching for other problem indicators.
> Also, copies of make.conf and src.conf are often essential in finding
> the cause of the problem.  Many build issues are caused by erroneous
> settings. :)

I installed world after the successful build, so now it probably is
too late to get a more useful problem report:(

By the way, I tried to add some debugging info with the help of make -d A
or -d g2 but the amount of logging was excessive(the build was ran in a tmux
terminal and the tmux process was using more CPU time than the build itself,
so I canceled). What should I use with "make -d" in order to get some basic
debugging? Or is there another way?

Thanks in advance, Nikos

More information about the freebsd-current mailing list