ath0: unable to attach hardware

Adrian Chadd adrian at
Fri Nov 9 16:45:24 UTC 2012

Can you use pciconf to dump the config space?

I think its pciconf -r <ath pci device string> 0:255



On 9 November 2012 01:57,  <husyh at> wrote:
> Hello again,
> the mail I'm replying to (and which is cited below) hasn't caused a reaction yet. Seeing that this mailing list has quite a lot of traffic, I'm worried that the mail, and the issue it tries to point out, will be forgotten.
> Should I file a bug report in hopes that the issue will somewhen be investigated/resolved?
> Again, I'm offering any kind of help I'm able to provide, i.e. delivering more information upon (hopefully detailed enough for me to understand) request, testing proposed fixes and doing some progamming on my own; for the latter, please keep in mind that I have no experience with the FreeBSD codebase or hardware programming.
> Thanks!
> On Samstag, 3. November 2012 at 11:43 AM, husyh at wrote:
>>Hello everyone,
>>I'm new to FreeBSD and wanted to install 9.0-RELEASE amd64 on a PC
>>I was given. At first glance, it seems like everything is working,
>>except the wireless LAN PCI card.
>>I started a thread on freebsd-wireless on the 31st of October (see
>>October/002511.html or a repost of my original message with proper
>>wireless/2012-October/002513.html )
>>Short summary:
>>The card has the strings "Anatel", "WN5301A-H1-V02" and
>>"KN160562*7" printed on it, although I'm not sure which, if any,
>>of those is a proper product number.
>>After setting
>>I receive
>>ath0: <Atheros 5413> mem 0xfdee0000-0xfdeeffff irq 16 at device
>>4.0 on pci2
>>ar5212ChipTest: address test failed addr: 0x00008000 -
>>wr:0x00000000 != rd:0xffffffff
>>ar5212Attach: hardware self-test failed
>>ath0: unable to attach hardware; HAL status 14
>>device_attach: ath0 attach returned 6
>>and am left unable to use the device.
>>I tried 8.3-RELEASE i386 as well as 10.0-CURRENT amd64 and i386
>>snapshots from (seemlingly
>>built a few days ago) and received the same messages, although I
>>did not get the debug messages since I booted off of the
>>installation media and therefore had a stock kernel, which
>>seemingly doesn't enable ATH_DEBUG and AH_DEBUG. Booting the
>>Ubuntu 12.04 amd64 installation media, I can use the NIC without
>>having any problems.
>>Adrian Chadd tried to help me via freebsd-wireless (thank you
>>again,) but ultimately asked me this:
>>"Please try a recent -HEAD i386 and amd64 snapshot and if that
>>work, you could try posting for help on freebsd-current. But please
>>stress that I think it's a bus enumeration and PCI bridge
>>problem, _not_ a driver problem."
>>And so I did.
>>I'd be very glad if you could try to help me. Of course, I'm
>>willing to provide any kind of information you might need, but
>>please keep in mind that I'm new to FreeBSD and therefore would be
>>thankful if you stated your instructions/requests in a newbie-
>>friendly way.
>>Thank you.
>>freebsd-current at mailing list
>>To unsubscribe, send any mail to "freebsd-current-
>>unsubscribe at"
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"

More information about the freebsd-current mailing list