[solved]: r2421600 amd64 /var/db/pkg

Darrel levitch at iglou.com
Sun Nov 4 15:09:45 UTC 2012

>>>     What you probably ran into is the common chicken and egg problem
>>> where
>>> if pkgng is upgraded ports, it blows up when it tries to deinstall the
>>> package, or similarly, when portmaster is upgraded, it doesn't halt the
>>> upgrade and restart it properly.
>>>     It's most likely still a problem; I'm going to doublecheck to make
>>> sure
>>> that's the case and file PRs if it is.
>> Thanks, Garrett.  For my current problem I am simply going to delete the
>> errant portmaster-3.14 from /var/db/pkg and then run 'portmaster -a -f
>> -D' with the hope that portmaster-3.14_7 can fix things.  If not I will
>> try reinstalling, the are only a few things installed- freeradius,
>> postgresql, and about a dozen others.
> This is overkill. You either have a pkg_install database or a pkgng
> database. Determining which will save you time.
> After you run pkg2ng, pkg_info will no longer work. It will complain
> about corrupted packages, since all the data is gone, but portmaster has
> stored additional information there, which confuses pkg_info.
> Check the output of 'pkg info'. If it lists all your packages, you are
> done. Nothing more to do.
> If not, run pkg2ng.
> Also, you can see any packages that have not converted with:
>    find /var/db/pkg -name +CONTENTS
> If nothing comes up, they are already all converted.

Thanks, Bryan.  Actually my fbsd10 machine already has portmaster 
reinstalling, which seems to be running alright.  It has less than two 
dozen packages on it.

I am looking at a fbsd9.1 machine right now, and it seems like a strange 
case considering your advice.  If I run 'pkg info' or 'pkg_info' then all 
of the packages are listed.  If I run 'find /var/db/pkg -name +CONTENTS' 
then all of the packages are found.  Yet on that machine in /etc/make.conf 
exists 'WITH_PKGNG=yes' and I ran pkg2ng on the 15th of October.


More information about the freebsd-current mailing list