Do we have a CPUTYPE=native and/or generic stability problem?

Dimitry Andric dim at
Sat Nov 3 23:46:13 UTC 2012

On 2012-11-03 23:24, Alexander Leidinger wrote:
> while trying to update from r239708 to r242511 (amd64 arch) I tried to
> compile the world with "make -j8". After a short while I got an
> internal error in the clang compile (this is a gcc-compiled system, I
> don't use clang). The CFLAGS/COPTFLAGS are -O2 -pipe.
> Without the -j8 it compiles just fine.
> Without the CPUTYPE?=native it compiles even with -j8.

Hm, at first I thought you might be running out of RAM, but apparently
that is not the case then. :)

> The CPU is an Intel(R) Xeon(R) CPU (L5630) with ECC ram.

What does gcc detect for this CPU with -march=native?  You can do:

   gcc -march=native -v -c -x c /dev/null 2>&1 | grep -- -march

to see what it passes to the second stage.

> The r239708 world runs stable since I installed it (build with
> CPUTYPE=native). The r242511 world (no CPUTYPE set) doesn't run stable
> (not only the watchdogd segfault I reported in another mail some minutes
> ago, but also some other kind of reboot every X minutes I haven't
> investigated yet).
> Does someone run -current on a similar system on a similar revision and
> can comment about the stability?

I run r242303 on both i386 and amd64, no instability whatsoever.  But I
compile everything with clang, and an explicit CPU type for the
processor in use, so my case is not comparable to yours, unfortunately.

More information about the freebsd-current mailing list