ath0: unable to attach hardware

husyh at husyh at
Sat Nov 3 10:42:49 UTC 2012

Hello everyone,

I'm new to FreeBSD and wanted to install 9.0-RELEASE amd64 on a PC I was given. At first glance, it seems like everything is working, except the wireless LAN PCI card.

I started a thread on freebsd-wireless on the 31st of October (see here: or a repost of my original message with proper formatting: )

Short summary:
The card has the strings "Anatel", "WN5301A-H1-V02" and "KN160562*7" printed on it, although I'm not sure which, if any, of those is a proper product number.
After setting


I receive

ath0: <Atheros 5413> mem 0xfdee0000-0xfdeeffff irq 16 at device 4.0 on pci2
ar5212ChipTest: address test failed addr: 0x00008000 - wr:0x00000000 != rd:0xffffffff
ar5212Attach: hardware self-test failed
ath0: unable to attach hardware; HAL status 14
device_attach: ath0 attach returned 6

and am left unable to use the device.
I tried 8.3-RELEASE i386 as well as 10.0-CURRENT amd64 and i386 snapshots from (seemlingly built a few days ago) and received the same messages, although I did not get the debug messages since I booted off of the installation media and therefore had a stock kernel, which seemingly doesn't enable ATH_DEBUG and AH_DEBUG. Booting the Ubuntu 12.04 amd64 installation media, I can use the NIC without having any problems.

Adrian Chadd tried to help me via freebsd-wireless (thank you again,) but ultimately asked me this:
"Please try a recent -HEAD i386 and amd64 snapshot and if that doesn't
work, you could try posting for help on freebsd-current. But please
stress that I think it's a bus enumeration and PCI bridge programming
problem, _not_ a driver problem."

And so I did.

I'd be very glad if you could try to help me. Of course, I'm willing to provide any kind of information you might need, but please keep in mind that I'm new to FreeBSD and therefore would be thankful if you stated your instructions/requests in a newbie-friendly way.

Thank you.

More information about the freebsd-current mailing list