Data corruption over NFS in -current

Martin Cracauer cracauer at
Fri Jan 13 14:38:00 UTC 2012

More findings.

Reminder, with the original report I found:
- files for no reason changing ownership and group to
- data corruption as in inserting binary junk obviously from ports
- data corruption as in malformed ascii text that might be a bug I
  have in my code that is only exposed in FreeBSD

I ran the script on a Linux machine in the same situation again the same
NFS server, it worked fine.  I haven't look at blocksizes, NFS
versions etc in play yet.

I ran with oldnfs (reboot), which showed only the third problem.

I re-ran with newfs (reboot) which worked (all three problems absent).

I then started building ports/land/gcc47 at the same time as I
re-started my crazy script and it too only a few seconds for an
unexpected ownership to root to occur.

My next steps are:
- trying block sizes and other parameters, maybe use a different NFS
  version with the Linux client.  My NFS server is newly upgraded to
  Linux kernel 3.1.5
- running my script on a FreeBSD host with local disk to see whether
  problem #3 is a general problem that appears or is exposed only on
- capture tcpdump as mentioned earlier

I will probably have to turn debug off since this script run is
dominated by system time now and gets 10x slower as it is now.

Martin Cracauer <cracauer at>

More information about the freebsd-current mailing list