multimedia/vlc: no graphical interface on FreeBSD 9 and 10

O. Hartmann ohartman at
Sun Nov 27 15:40:17 UTC 2011

Since a while, vlc on my FreeBSD 10 and FreeBSD 9 boxes do not show a
graphical interface anymore. Compiling multimedia/vlc works, either with
the legacy gcc or clang. But either way I compile vlc, the result is
always the same: no GUI. Instead, I receive the below show message:

VLC media player 1.1.12 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x802080a70] main interface error: no suitable interface module
[0x8020691b0] main libvlc error: interface "globalhotkeys,none"
initialization failed
[0x8020691b0] main libvlc: Running vlc with the default interface. Use
'cvlc' to use vlc without interface.
[0x802080a70] main interface error: option qt-volume-complete does not exist
[0x802080a70] skins2 interface error: no suitable dialogs provider found
(hint: compile the qt4 plugin, and make sure it is loaded properly)
[0x802080a70] skins2 interface error: cannot instanciate qt4 dialogs

I tried several times to recompile everything vlc depends on, but with
not success. I also tried to delete every configuration file vlc created
in the past and my now suffer from legzy options, but that hadn't any
effect - as far as I could catch each config file.

Is anybody out here having had the same or similar problem and solved it?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 552 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-current mailing list