loader crash / BTX halted on 9.0-RC2 DVD with AMD pseudo-RAID

John Nielsen lists at jnielsen.net
Wed Nov 23 03:18:57 UTC 2011

On Nov 22, 2011, at 10:26 AM, John Baldwin <jhb at freebsd.org> wrote:

> On Monday, November 21, 2011 1:45:36 pm John Nielsen wrote:
>> This weekend I downloaded the Freebsd 9.0 RC2 amd64 ISO image and burned it 
> to a DVD. I have a computer that currently runs Windows 7 but I plan to 
> install FreeBSD on it in the near future so I booted it up from the DVD to 
> check the hardware/driver status. Much to my dismay, the boot loader crashed 
> right away (register dump followed by "BTX halted") and the computer 
> immediately rebooted. I took a video with my phone so I could capture the 
> crash message, screenshot here:
>> http://picpaste.com/pics/BTXcrash.1321899682.jpg
>> I then tried tweaking a few BIOS settings and found that turning off the 
> built-in pseudo-RAID allowed the DVD to boot normally. I changed the SATA type 
> from "RAID" to "AHCI". Fortunately I plan to use the controller in AHCI mode 
> for the FreeBSD installation so this won't end up being a problem for me, but 
> I still thought it was worth reporting.
> Hmmm, so this is odd.  It died with an Invalid TSS exception on the iret 
> instruction at the end of the return-from-real-mode trampoline in BTX.  
> Looking at the dump I noticed that PSL_NT is set in %eflags, so for some 
> reason the iret was trying to do a nested task return.  We shouldn't let
> that flag leak out of any real mode code.  Try this patch perhaps:

Thanks for looking!

I put gptboot on a USB stick and tried it with and without the patch. Identical behavior in both cases to booting from the DVD (only faster)--BTX dump and an instant reboot. I didn't do a screen capture yet but will be happy to tomorrow if it will help.


More information about the freebsd-current mailing list