Adding disk firmware programming capability to camcontrol

Andriy Gapon avg at FreeBSD.org
Sun Nov 20 15:24:48 UTC 2011


on 20/11/2011 16:54 Pegasus Mc Cleaft said the following:
> Hi Nima, 
> 
> 	I have tried your latest patch against current, but I am having difficulty 
> getting it to work. I was wondering, is this feature limited to SCSI drives?  
> I have been trying it against my SATA drives but it looks like it is failing 
> on issuing a TUR. 
> 
> IE: 
> 
> feathers# camcontrol fwdownload ada5 -f JP0NB3MA.BD -s -v
> Running in simulation mode
> camcontrol: Device is not ready
> (pass5:ahcich4:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0 
> (pass5:ahcich4:0:0:0): CAM status: CCB request was invalid
> Firmware download failed
> 
> 
> I have tried issuing a TUR to all my drives to see if it was controller or 
> drive specific, but all of them return the same error (The drives are Seagate, 
> Hitachi and WD). 
> 
> What am I doing wrong?

You are sending SCSI commands to a (S)ATA drive.

-- 
Andriy Gapon


More information about the freebsd-current mailing list