IPv4 broken on r222048

Garrett Cooper yanegomi at gmail.com
Tue Jun 7 18:11:11 UTC 2011

On Tue, Jun 7, 2011 at 11:00 AM, Garrett Cooper <yanegomi at gmail.com> wrote:
> On Tue, Jun 7, 2011 at 10:41 AM, Bjoern A. Zeeb
> <bzeeb-lists at lists.zabbadoz.net> wrote:
>> On Jun 7, 2011, at 5:29 PM, Garrett Cooper wrote:
>>> Hi,
>>>    I'm running into an issue where ifconfig isn't executing properly,
>>> and is emitting the following message:
>>> # ifconfig re0 inet w.x.y.z
>>> ifconfig: can't set link-level netmask or broadcast
>>> #
>> ...
>>>    I haven't traced down what commit exactly is causing this, but the
>>> issue appears to be a purely userland based problem so far (I
>>> accidentally forgot to swap kernels before booting up the second time
>>> and the symptoms are exactly the same).
>> Yes, you lost.  My changes did that.  You are the second to hit it.
>> Your kernel does not have "FEATURES()"  present and the new user space
>> that came a couple of days later expect it and disable your IPv4
>> because of that.
>> The real problem is when people update the kernel, then update world
>> and then figure out they need to go back to kernel.old.
>> I'll add an UPDATING entry.
> That I would expect, but I just built the kernel last night, installed
> it, and am running it right now and I run into the same issue as I do
> with the older kernel :). Was there any magic foo that I needed to use
> to get FEATURES working properly, or was it supposed to be seamless? I
> don't know because I never had a need to fiddle around with the
> framework..
> Is there a tool I can use (minus banging on the interfaces in C) to
> determine what the features are on the machine to diagnose why things
> aren't working for me?

Answering my own question:

sysctl kern.features.inet
sysctl kern.features.inet6

Hmmm... they turn up unknown OIDs. Need to do some digging to discover
why that's the case..

>> You need an old user land or a new kernel to recover.
> Looks like I need an old userland, because a new kernel/userland combo
> doesn't seem to work as advertised :/...
>>>    I have both INET and INET6 built into my kernel and userland, but
>>> my immediate upstream router only supports IPv4 right now. I tried
>>> building with WITHOUT_INET6=yes to see if it made a difference, and it
>>> didn't.
>>>    I'll test any patches needed to remedy the issue. Thankfully I
>>> have flash media I can use in the meantime to push code between my two
>>> boxes :)
>> Welcome to FreeBSD HEAD, being a developer and not following the rule;-)
>> Sorry for the hassle though.
> It's ok -- that's why I have two near workstations -- one for daily
> use and the other for testing :).


More information about the freebsd-current mailing list